OS X 10.8.5 can't set permissions for external hard drive.

Discussion in 'macOS' started by frnc, Feb 14, 2014.

  1. frnc macrumors newbie

    Joined:
    Feb 14, 2014
    #1
    Under Sharing & Permissions there's only "You can only read". No other options available. No lock either.

    Any ideas?

    Thanks.
     
  2. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #2
    What format does the external drive use? It is listed under FORMAT.

    [​IMG]
     
  3. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #3
    What format is the external hard drive?
    You can right-click on the hard drive, and choose Get Info.
    If the format is NTFS, then that will be read-only on a Mac.

    You can either re-format that drive as a MacOS Extended format (which will erase the hard drive completely) or you could also download and install one of the NTFS drivers, such as from Tuxera.
    http://www.tuxera.com/products/tuxera-ntfs-for-mac/
     
  4. Barney63 macrumors 6502a

    Barney63

    Joined:
    Jan 9, 2014
    Location:
    Bolton, UK.
    #4
    Is there no similar program to AOMEI that can be used?
    AOMEI can convert NTFS>FAT32 and FAT32>NTFS without losing data.

    Barney
     
  5. frnc thread starter macrumors newbie

    Joined:
    Feb 14, 2014
    #5
    Ok, the external drive is actually NTFS formatted. I deleted all files on it anyway, so no worries about loss of data. How can I reformat it to... HFS?

    Ideally I would like to use the ext drive both for MAC and PC.
     

    Attached Files:

  6. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #6
    You can do that easily on your Mac.
    Launch Disk Utility.
    Choose that external drive (not the Elements partition line, but the line directly above it with the manufacturer's info.)
    Click the Partitions tab.
    Click the drop down under Partition Layout.
    Change to 1 Partition (or more, your choice)
    Format should show Mac OS Extended (journaled)
    Name your partition, if you like.
    Click the Options button, near the bottom of the window, and change to GUID, and click OK.
    Click the Apply button. And, wait for a few seconds, and your drive is fully usable on your Mac (and NOT fully usable on Windows. If you need Windows, too, then there's other solutions for that, too)
     
  7. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #7
    OSX cannot set permissions on NTFS. If you're going to use this for both then I'd recommend using exFAT as the format. You can avoid buying applications to give Windows the ability to read/write HFS+ partitions and conversely if you go with the NTFS format you can avoid buying a utility to give OSX the ability to write to NTFS volumes.
     
  8. frnc thread starter macrumors newbie

    Joined:
    Feb 14, 2014
    #8
    Thanks Everybody.
    I appreciate your help.
    I have used ExFAT as format to use the drive for both MAC and Windows.
    The drive does work on my MAC now, but not on my Windows machine (...). I tried to select in Options both GUID and later Master Boot, but this didn't seem to help. My PC still tells me that the drive is not formatted. And it shows only NTFS as possible format (hence not possible to format it as ExFAT from my Windows). Could it be because my PC, to use an euphemism, is not the newest one on the market?
     
  9. chown33 macrumors 604

    Joined:
    Aug 9, 2009
    #9
    ExFAT is a software capability. The hardware has no direct relevance.

    What version of Windows are you using?
    http://en.wikipedia.org/wiki/ExFAT
    ... It is supported in Windows XP and Windows Server 2003 with update KB955704,[2] Windows Embedded CE 6.0, Windows Vista with Service Pack 1,[4] Windows Server 2008,[5] Windows 7, Windows 8, Windows Server 2008 R2 (except Windows Server 2008 Server Core), Mac OS X Snow Leopard starting from 10.6.5,[6] Mac OS X Lion, OS X Mountain Lion, and OS X Mavericks.​
     
  10. frnc thread starter macrumors newbie

    Joined:
    Feb 14, 2014
    #10
    I am using Windows XP (2002).
     
  11. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
  12. frnc thread starter macrumors newbie

    Joined:
    Feb 14, 2014
  13. Kon Iatrou macrumors newbie

    Kon Iatrou

    Joined:
    Mar 5, 2017
    #13
    This is brilliant! Saved the day big time. Has the same exact problem. The fix is in the padlock on the bottom right hand corner. Clicked on it and I changed the Read only permission to Read and Write and then applied the changes to the whole drive using the gear icon and selecting "Apply to enclosed items ...". Then the whole drive was once again accessible.

    Thanks to all assisted :)
     

Share This Page