OS X 10.8 - Can't install fonts?

Discussion in 'OS X Mountain Lion (10.8)' started by Akele, Aug 23, 2012.

  1. Akele macrumors newbie

    Jul 16, 2011
    Hey guys, I've recently upgraded my late 2011 Macbook Pro to Mountain Lion, and now I can't seem to install fonts. Two scenarios happen when I try to install a new font - the first gives me a window stating there's an error in the name table or something similar to that, the second opens up Fontbook and actually looks like it's processing/installing something, but no results happen, as if it's processing something... for nothing... Any ideas or help would be great! This is really troubling me, because I do some graphics designing, and sticking to the computer's default fonts is a little troubling.
  2. jlocalled macrumors member


    Oct 13, 2008
    You could try copying the font file into your ~/Library/Fonts folder and seeing it shows up in Font Book.

    It could also be a bad file. Have you tried other font files?

  3. satcomer macrumors 603


    Feb 19, 2008
    The Finger Lakes Region
    To get to your Home Library in 10.7 or 10.8 just click on the desktop. Then, while holding down the 'alt/option' key and in the Finder menu 'Go select 'Library' (while still holding down the 'alt/option' key). Then install your fonts in the Fonts folder.

    Then use /Applications/Font Book to verify your new fonts. Plus you could just font Book menu item 'File' and select 'Add Fonts'.
  4. Akele thread starter macrumors newbie

    Jul 16, 2011
    I've tried all of the above methods, dragging the font file into Home, Mac, and System libraries. I've tried double clicking the font and clicking "install font", and also using the File>Add Font and the + button. These all don't seem to be installing the font for me.
  5. RonaldTreur macrumors newbie

    Aug 30, 2012
    Same problem here..

    I have the exact same issue. The installer notes there is a 'minor' issue (details mention this being the "'name' table structure"), and present me the option to check a box to continue anyway.

    So, I check the box and press Install. It seems to be doing something for a short while and no dialog appears anymore afterwards. But after checking, the font has not been installed. I tried this several time, for multiple fonts. No luck..

    I tried this on a new MBP Retina, that came with 10.7.4 pre-installed, which I immediately upgraded to 10.8. I tried to install the font using 10.8 and 10.8.1.

    I did manage to install this font (TTF) on my old MBP (running 10.7), which I then upgraded to 10.8. That worked perfectly. Similar case with a friend's MBP.

    To me, it looks like a bug in 10.8 is preventing the installation of new fonts to the system.
  6. BG21 macrumors newbie

    Sep 26, 2012
    After trying lots of the solutions listed above, and elsewhere, I finally came up with a solution that worked for me.

    It turns out my trouble with some of my older fonts was due to the fact that when I upgraded to ML (from Lion) I had migrated my files into ML from a different user's account. When the font files migrated the 'sharing and permissions' settings, (you know - under 'get info') for each font was restricted to "read only" or 'no access' for my new (ML) user.

    So for each font (sigh) I had to open 'Get Info', unlock the 'Sharing and Permissions', then change the setting to 'Read and Write' for my new user account.

    After that all the fonts that would appear to load, but not show up in Font Book were where they belonged.

    I hope this helps someone else!
  7. vitaprimo macrumors newbie


    Sep 26, 2012
    La Paz, BS. Mexico.
    Accidental solution

    I read all of your answers and, looking for a solution myself, I think I just accidentally came up with one.

    I kept opening fonts just by double clicking the file and then clicking on install. I didn't install them, nor by clicking [+] on Font Book.

    "Install Font" would summon Font Book but the Font wasn't there, it just looked like it made the effort to install it. So I looked into the user Fonts [username/Library/Fonts] folder and saw the font file was indeed there it just wasn't read by Font Book or any application.

    So I dragged it to the all users Font folder [/Library/Fonts] and before opening Font Book again, I just opened the file directly from the Font folder and this time it did install the font.

    I'm running 10.8.2 Server, before Mountain Lion I didn't have these issues. Also, in a desperate move in Font Book I clicked in Restore Standard Fonts under the File menu and told me I needed to reinstall the OS because of some random problem; I was just about to boot from the Recovery disk when I gave it another chance and found this. :)
  8. slinxy macrumors newbie

    Jan 28, 2012
    sorry if this is a bit late...

    By the looks of things ML don't create a fonts folder per user as previous OS versions did.

    I just created a new collection in font book and then all previous methods worked like in the previous os versions.
  9. SewGrami macrumors newbie

    Jan 3, 2013
    still won't work

    I am fairly new to the Mac world. I am using an MBP 15"w/Retina running ML updated to most recent. I have only tried to to download 2 fonts. The first time worked exactly as expected. The second one is giving me the 'minor error' name table. I installed anyway, it appeared to do so, but is not available in Word. I tried restarting, nothing. I then went to manually drag it into Library/Fonts, as previously mentioned, only to find it is indeed already there, (along with the other one I had downloaded). Interesting note. I just now tried opening a different app... (software to create files for my Silhouette Cameo (a vinyl cutter machine)) The font in question IS there!! This app is run on Mac side btw, as is MS Office. I also tried installing the troubled font in Parallels, win 7. installed with no trouble, and shows up in my embroidery software in Windows. Why will it not show up in Word?? Thanks!
  10. Cuechick macrumors 6502


    May 30, 2010
    So Cal
    So dose installing ML wipe out all your previously installed fonts or is this only an issue for new fonts? I am upgrading right now and have about 100 fonts added to font book. I will be very upset if they are no longer there.
  11. talooz macrumors newbie

    Apr 17, 2013
    I am having issues with FontBook also;
    I have upgraded all my macs to Mountain Lion 10.8.3
    I have one Mac Mini, Mid 2011, 2.5 GHz Intel Core i5 who is giving me a hard time dealing with those fonts. except from the extreme slowness when loading fonts, the big problem is that I need to disable all activated fonts and re enable them again, each time I boot the computer in order to get it working.
    I have checked all the fonts for corruption and on all other macs I don't have this problem.
    Before I got mountain lion I was using Font ExplorerX and i had no issues.

    Any ideas how can I fix this?
    Thanks :p
  12. justperry macrumors G3


    Aug 10, 2007
    In the core of a black hole.
    Try deleting Font Caches, easiest way is to download Onyx (For Mountain Lion) and run it.
    Screenshot below.

    Attached Files:

  13. dkgee macrumors newbie

    Aug 3, 2010
    Park City UT
    Same Install Problem - This worked for me...

    So I dragged it to the all users Font folder [/Library/Fonts] and before opening Font Book again, I just opened the file directly from the Font folder and this time it did install the font.

    Moving the added font from the User folder to the Library/Fonts folder fixed it.
  14. chueter macrumors newbie

    Mar 30, 2016

    for me it worked when I deleted manually the ttf files from the font directory where they were located, then downloaded the font files once more, then choose 'validate file' in font book and 'install'.



Share This Page