OS X 10.8: iMessage status error

VulchR

macrumors 68020
Original poster
Jun 8, 2009
2,396
11,622
Scotland
Just upgraded and everything seemed fine. However, I just discovered that my iMessage status in the menu bar is 'Offline' and when I try to click 'Available' nothing happens. In the iMessage app, the 'Messages>My Status' menu items are all dimmed. I have confirmed that the correct me.com account information is listed in the preferences, and also that messages sent via my computer are synched with my iPhone. However, nothing is coming in.

One more thing: there used to be a synch button in the menu bar, but is no longer there - is this normal?
 

ckFoxtrot

macrumors newbie
Sep 4, 2009
5
0
I am experiencing the same issue with iMessage statuses.

My system menu icon up top is grayed out, but if I click it, my drop down of selectable statuses are not. However, no matter what status message I select, "Offline" remains selected.

Interestingly, however, even though my selected status here remains on "Offline," if, say, I do select "Away," my selected status in the Messages (the program itself) drop down menu, under "My Status," will reflect whatever I chose in the system menu drop down!

All of the status options in the Messages drop down are grayed out and it won't let me click on any of them.

I guess there is some bug affecting cooperation between iMessages and the system bar icon.

My messages do sync up with my iPhone though, which is good. Also, I have iMessages set to remain open even if I close its window. The status issue happens whether it is open or not.


Not sure what might have happened to your Sync system bar icon VulchR, mine is still up there.
 

westvik1

macrumors newbie
Jul 25, 2012
2
0
almost same problem, only to me, they asks for password over and over again when i hit the button that says "offline"
sollutions?
 

Smoothie

macrumors 6502a
Jun 23, 2007
651
389
California
Same problem for me. "My status" has options grayed out. It's stuck on "available."

UPDATE: I just solved it. You need to enable the Bonjour account in Messages.
 
Last edited:

dissdnt

macrumors 65816
Aug 3, 2007
1,488
1
I tired the bonjour thing and nada still won't work. Keeps spinning on enable account.

UPDATE: kinda weird but if you sign out in the iMessage settings and then log back in using your appleid@icloud.com not @me.com it works.. but not sure this is syncing across devices.

UPDATE2: Ahh I see what I did. My imessage is setup to my appleid i use for itunes/app store etc.. not my icloud account.. god this crap is confusing. Apple needs to allow you to manage and merge these accounts. All is well now.
 
Last edited:

gfeen

macrumors newbie
Nov 29, 2011
12
3
Similar issue

I'm having the same thing. Keeps asking me to enter my password and then will work for a little bit and then asks me to reenter it
 

MacHiavelli

macrumors 65816
May 17, 2007
1,150
710
new york
Just upgraded and everything seemed fine. However, I just discovered that my iMessage status in the menu bar is 'Offline' and when I try to click 'Available' nothing happens. In the iMessage app, the 'Messages>My Status' menu items are all dimmed. I have confirmed that the correct me.com account information is listed in the preferences, and also that messages sent via my computer are synched with my iPhone. However, nothing is coming in.

One more thing: there used to be a synch button in the menu bar, but is no longer there - is this normal?
Having the same issue on a MBP and iMac. Did you find a solution?

If you look under Video > Connection Doctor > Network Status, do you have "Port Restricted" as an error notice?

TIA

Mac
 

VulchR

macrumors 68020
Original poster
Jun 8, 2009
2,396
11,622
Scotland
Same problem for me. "My status" has options grayed out. It's stuck on "available."

UPDATE: I just solved it. You need to enable the Bonjour account in Messages.
This worked for me as well. Erm... what the heck is Bonjour? :eek:

Having the same issue on a MBP and iMac. Did you find a solution?

If you look under Video > Connection Doctor > Network Status, do you have "Port Restricted" as an error notice?

TIA

Mac
No, but I checked this after I resolved the problem (see above). Everything seems to work now, but I no longer have a synch button in the menu bar. Maybe this is no longer needed?
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.