OS X 10.9.2 wi fi is dropping

Discussion in 'OS X Mavericks (10.9)' started by davorp, Mar 12, 2014.

  1. davorp macrumors newbie

    Joined:
    Jul 28, 2011
    #1
    A few days ago I have finally decided to upgrade from Lion to Mavericks. Everything is working as it should but my wi-fi. My Internet connection is freezes up and stalls and it's very annoying. I have tried different workarounds including the open DNS, but that did not help. Wi-Fi on other devices is very stable. My rougher is AirPort Extreme. Any ideas of how to fix this permanently?
     
  2. MatsSkoe macrumors member

    MatsSkoe

    Joined:
    Jul 28, 2013
    Location:
    Rotterdam
    #2
    The only thing I notice is that my Wi-Fi connection is lost after sleep. Normally I opened the lid, typed in password and had instant connection. Now it takes 10-20 seconds.
     
  3. 844957 Suspended

    Joined:
    Sep 16, 2013
    #3
    I also experience the slow to reconnect to my wifi

    another problem is that my imac loses its ip address after sleep and it tries to connect with a taken address

    and i have to turn off wifi/forget network/ or wait till it dchp a new ip address 1 number up from the one it wants to connect with

    10.9.2 made this worse
     
  4. Orlandoech macrumors 68040

    Orlandoech

    Joined:
    Jun 2, 2011
    Location:
    Salt Lake City, UT
    #4
    Having this issue too, super annoying. I have to turn WiFi off and then back on to get my rMBP to reconnect.

    Anyone have a solution?
     
  5. phillytim macrumors 6502a

    phillytim

    Joined:
    Aug 12, 2011
    Location:
    Philadelphia, PA
    #5
    Allow me to chime in here as another victim of the Wifi-reconnect issue, which I've been experiencing noticeably since 10.9.1.

    Please, complain to Apple: http://www.apple.com/feedback/

    Whining about it here alone won't do any good.
     
  6. caribiner23 macrumors regular

    caribiner23

    Joined:
    Feb 15, 2005
    Location:
    Chicago
    #6
    Same here.

    The funny thing is that my rMBP almost always tries to grab the IP that my iPhone has. I can make the problem go away most of the time by turning off Wifi on my phone.
     

Share This Page