Os X...arrrrgh!

Discussion in 'macOS' started by SiliconAddict, Oct 9, 2007.

  1. SiliconAddict macrumors 603

    SiliconAddict

    Joined:
    Jun 19, 2003
    Location:
    Chicago, IL
    #1
    I really think this damn OS hates me. So I went to reboot into Windows to do some gaming and I get this on shutdown...

    [​IMG]


    Oh and yes I do see what is going on behind the scenes. I enabled verbose mode earlier this year so I can see what is going on. Basically is stops processing after it says continuing. At which point I can type whatever I want.

    Here is a med res video: http://home.comcast.net/~jonnormand/MOV00002.MPG

    Oh OS X...why do you hate me so? I NEVER had this many issues with Windows. Never. :mad:

    PS- Yes I repaired permissions and followed these instructions to remove startup items: http://www.dssw.co.uk/sleepcentre/threads/tiger_won_t_shut_down_or_restart.html
     
  2. displaced macrumors 65816

    displaced

    Joined:
    Jun 23, 2003
    Location:
    Gravesend, United Kingdom
    #2
    Weeeird :)

    I've not see that happen since 10.1 or so on my old iMac G3!

    Just a hunch... try resetting the NVRAM:

    - Power-on from cold
    - As the chime sounds, hold Command+Option+P+R
    - The machine will restart.

    Also, for completeness' sake, reset the System Management Controller:

    - Shut down
    - Remove all power (AC lead, battery)
    - Hold the Power button down for 15-20sec.
    - Reconnect battery.

    I'll have a google around and see what else I can find!

    Good luck,

    [Update]

    Also, try doing a safe boot:

    - Power on
    - At the chime, hold the Shift key.
    - Keep held down until you get to the Login window

    At this point, try clicking the Shutdown button on the login window to see how it behaves when it shuts down.

    Then,

    - Repeat the safe boot steps above
    - Now, at the login screen, click your username and enter your password
    - Click the Login button, then immediately hold the Shift key
    - Keep held down until you've logged in.

    This will do a Safe Login in addition to the Safe Boot.

    Then, try shutting down immediately to see how it behaves. I've assumed you've got your mac set to boot into the login screen instead of automatically logging in as a particular user. If it's not, set it so in System Preferences. Shutting down from the Login screen's a good test, since at that stage, no user-specific stuff has been loaded yet. Plus, the Safe Boot and Safe Login steps ensure that only Apple-supplied programs and libraries are loaded.

    [Update 2]

    Also, how did you enable Verbose boot? Have you made it a permanent change, or are you doing it by holding Command+V at the startup chime? Reason I ask is I think when my old G3 iMac did this, it was because I'd tinkered with something to always give a Verbose start. Starting this way seems to launch the GUI server in a slightly different manner to a regular boot -- possibly something to do with how the underlying terminal (tty) is forking the shell process... or possibly because the tty doesn't background itself deliberately so that shutdown warnings can be viewed onscreen.
     
  3. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #3
    What does it say there after shutdown?


    Oops, nevermind, I see your picture finally loaded now. Seems not to load unless I see the movie.


    Maybe OS X Hates you because you call it OS Ex, and not OS Ten, the way it's supposed to be called. :)


    mdimport is part of Spotlight.. but "sniffer".. that seems odd to me. Seems it might be part of a debugger.

    Does this happen if you logout from another account?
     
  4. phillipjfry macrumors 6502a

    phillipjfry

    Joined:
    Dec 12, 2006
    Location:
    Peace in Plainfield
    #4
    try turning off spotlight indexing and see if that makes the problem go away
     
  5. pknz macrumors 68020

    pknz

    Joined:
    Mar 22, 2005
    Location:
    NZ
    #5
    You could just go back to Windows if your getting to the end of your tether with OS X. Sorry I really just wanted to use the word tether, it is an option however.
     

Share This Page