OS X-can't get ANY networked printer set up (EEK!)

Discussion in 'Mac Basics and Help' started by Wolfpup, Sep 28, 2007.

  1. Wolfpup macrumors 68030

    Joined:
    Sep 7, 2006
    #1
    (I saw the "peripheral" forum, but this seems more like a networking or general type problem since the issue isn't with the printers).

    So I've got my new Macbook Pro here, and I can't get it to print to ANY networked printer at all.

    -One printer I typically just print directly to the IP address. In Windows it takes 2 seconds to set up. On OS X, I SEEM to be able to set it up just as fast. I pick IP printing, punch in the IP address, it autofills in the model, fills in the location, even lets me see how much toner is left. But when I try to print to it, it gives me:

    "Unable to get printer status (server-error-operation-not-supported)!" (The exclamation point is in the error message, I didn't add it.)

    -The rest of the printers I normally go through a server to print to. I assume a Windows server (Windows prompts me for my domain credentials when printing to them if I'm not logged in to a domain).

    I've tried setting up those printers multiple times, multiple ways. Browsing through the domain in the printer setup utility, trying to use the direct path to the resource, etc.

    Regardless of what I do, I get an error like:

    "Unable to connect to SAMBA host, will retry in 60 seconds...DEBUG: 0 %%Page: 1 1"

    And then I get something like:

    "Connection failed with error NT_STATUS_LOGON_FAILURE"

    I've seen this page:

    http://docs.info.apple.com/article.html?artnum=301768

    Which seems like it might be relevant. It acts like you can't have special characters in a password to connect-except 1) I *HAVE* to have special characters, and 2) I'm never prompted for my credentials.

    I've tried setting up the printer in the form smb://user:password@server/sharename, which doesn't work either.

    I've also tried printing to a printer shared off of a normal XP machine-that one actually prompts me for credentials at the time I try to add it, but doesn't accept them.

    So...maybe there are two issues here? Maybe OS X can't print to a resource that has a complex password?

    That's going to be a deal breaker for me if it's really true...but what's causing it's inability to print to an IP address? That doesn't require a password, it's just not working.

    Any ideas?
     
  2. Wolfpup thread starter macrumors 68030

    Joined:
    Sep 7, 2006
    #2
    I do have an update of sorts-A coworker who uses Macs was able to at least get me set up with printing directly to a printer. It turns out for a Laserjet on the IP Printer tab you need to pick "HP Jet Direct - Socket" rather than "Internet Printing Protocol"-apparently it pretty much just picks a different port.

    Unfortunately he wasn't sure how to get it to print through a queue, which is bad considering he's really knowledgeable, and a networking guy. I'm wondering if basically OS X dosen't REALLY support it-that knowledge base article about not being able to use passwords with "special characters" kind of sounds like support is flaky.

    Our support desk gave up too big_smile Oh well, I guess if I can kinda sorta print directly to most of these printers that's probably good enough, but I'm open to any other ideas.
     

Share This Page