OS X Crashes if I plug in external USB WD500 HDD used for Time Machine

Discussion in 'macOS' started by PhilCox1984, Nov 4, 2008.

  1. PhilCox1984 macrumors newbie

    Joined:
    Oct 29, 2008
    #1
    So....... for some reason my Mac crashes if I plug in the USB HDD I have been using for Time Machine on my :apple: MBP (Late 2008).

    There are also two other partitions on HDD, one FAT and one Mac.... not sure which. I have not actually used either of these partitions yet. Only the Time Machine partition. I used the same MBP to make the 3 parts using DU.

    If I plug it in I get a grey screen telling me to hold down power to reboot. :mad:

    If I boot with the HDD attached then it gets so far but hangs before Login screen. :mad:

    I am happy to format the HDD. Not sure how, as I dont have another mac to see if it works on that.

    My work Win PC can read and write the Fat partition, so I don't think the error is with the physical HDD. Is there a way to format the entire 500GB in XP, even though I can only see a 70GB partition ? ? I am happy using DOS command line if needed... can't find any DU type application in XP.

    I'll be very happy for any help / ideas ? ! :)

    Regards,

    Phil
     

    Attached Files:

  2. BobZune macrumors 6502a

    Joined:
    Oct 26, 2007
    Location:
    USA
    #2
    On the work PC, copy the data from the FAT partition, then delete all partitions. Then format the drive to FAT32 (it will use the MBR partition map). Then the MBP's DU will recognize it. Now you can partition it, but use GUID partition scheme if you are going to use it for Time Machine. Better not to use it in a Windows machine (i.e., I'd recommend not having a FAT/FAT32 partition on a GUID partition mapped drive). See
    http://discussions.apple.com/thread.jspa?messageID=8200667&#8200667 if you need partition instructions.
     
  3. PhilCox1984 thread starter macrumors newbie

    Joined:
    Oct 29, 2008
    #3
    Thanks but...

    Thanks for reply. I tried that, OS X still crashed with same error as shown in attchment above when I plug the darn thing in to the USB port. Argh ! :confused:

    I will purchase/borrow another USB externall HDD to see if they all crash my MBP or if its just that the one I have now....
     
  4. BobZune macrumors 6502a

    Joined:
    Oct 26, 2007
    Location:
    USA
    #4
  5. PhilCox1984 thread starter macrumors newbie

    Joined:
    Oct 29, 2008
    #5
    Yea I've tried it in safe mode and it behaves the exact same way.

    Tried both USB ports.

    From reading the error message its got something to do with the I/O on the USB being reserved ??

    USB mouse & digi cam etc. all work as per normal.

    I am fairly sure its an issue with USB in someway rather than the format of the drive. I disk checked it in XP and its 100 % ok, now formatted NTSC.

    Cheers !
     

Share This Page