OS X disc missed out graphic drivers?

Discussion in 'Windows, Linux & Others on the Mac' started by daveylex, Aug 8, 2009.

  1. daveylex macrumors newbie

    Joined:
    Aug 8, 2009
    #1
    I've installed Windows XP with Service Pack 2 a couple days ago - figured out the drivers stuff and finally the OS X disc ran flawlessly, installed most of the drivers for internet,audio and isight .. whatever.

    I thought it's done so I installed GTA:Vice City on my Windows XP - when I tried launching the game, it gave me an error stating 'Couldn't find enough video memory'.

    So I went to Start>Run and typed in dxdiag which opens the DirectX Diagnostic Tool. I went to 'Display' and found out that the category under 'Device' is completely blank with DirectDraw Acceleration and Direct3D Acceleration stating 'Not Available'. Am I missing out the graphic driver or something? I don't know much about this drivers and I would appreciate it if anyone here explains it and provide a link where to install these required drivers.

    By the way, I've tried installing the driver off NVIDIA's site but still it turns out funny..

    Using iMac 10.5.6 - 2.66 GHz - NVIDIA GeForce 9400M.

    Thanks in advanced.
     
  2. Markov macrumors 6502

    Markov

    Joined:
    May 18, 2007
    Location:
    Philadelphia
    #2
    I'm going to assume that the GPU cannot handle GTA Vice City, but I do not know the specs off the top of my head. Try uninstalling every trace of a video driver (via device manager) and then reinstall the nVidia drivers. Also, did you use Apple Software update?
     
  3. t3heford macrumors member

    Joined:
    Jul 1, 2009
    #3
    I'm not exactly sure but I'm SURE that the 9400m can run GTA VC. I've seen videos of GTA4 running on a mbp 13, so the 15 should have no problem at all...sorry I'm no help though :D
     
  4. daveylex thread starter macrumors newbie

    Joined:
    Aug 8, 2009
    #4
    Okay I installed this Nvidia driver and when I check again from dxdiag under the Start>Run, I can see it there under Devices with DirectDraw and AGP Texture Acceleration 'Enabled' but not Direct3D Acceleration. I can also see the Approx. Total Memory is like 512MB but still GTA fails to launch.
     
  5. daveylex thread starter macrumors newbie

    Joined:
    Aug 8, 2009
    #5
    Operating System: Microsoft Windows XP Professional (5.1, Build 2600) Service Pack 2 (2600.xpsp1.020828-1920)
    Language: English (Regional Setting: English)
    System Manufacturer: Apple Inc.
    System Model: iMac9,1
    BIOS: APPLE - 8d
    Processor: Intel(R) Core(TM)2 Duo CPU E8135 @ 2.66GHz (2 CPUs)
    Memory: 1768MB RAM
    Page File: 213MB used, 3453MB available
    Primary File System: NTFS
    DirectX Version: DirectX 8.1 (4.08.01.0810)
    DX Setup Parameters: Not found
    DxDiag Version: 5.01.2600.1106 32bit Unicode

    Card name: NVIDIA GeForce 9400
    Manufacturer: NVIDIA
    Chip type: GeForce 9400
    DAC type: Integrated RAMDAC
    Device ID: Enum\PCI\VEN_10DE&DEV_0867&SUBSYS_00AD106B&REV_B1
    Display Memory: n/a
    Current Mode: 1680 x 1050 (32 bit) (60Hz)
    Monitor: Default Monitor
    Monitor Max Res:
    Driver Name: nv4_disp.dll
    Driver Version: 6.14.11.8585 (English)
    DDI Version: Unknown
    Driver Attributes: Final Retail
    Driver Date/Size: 4/30/2009 22:02:00, 5896320 bytes
    Driver Signed: Yes
    WHQL Date Stamp: n/a
    VDD:
    Mini VDD: nv4_mini.sys
    Mini VDD Date: 4/30/2009 22:02:00, 8055584 bytes
    Device Identifier: {D7B71E3E-4B27-11CF-5252-A62010C2CB35}
    Vendor ID: 0x10DE
    Device ID: 0x0867
    SubSys ID: 0x00AD106B
    Revision ID: 0x00B1
    Registry: OK
    DDraw Status: Not Available
    D3D Status: Not Available
    AGP Status: Not Available

    Help still needed please.
     
  6. Rodus macrumors 6502a

    Rodus

    Joined:
    Oct 25, 2008
    Location:
    Midlands, UK
  7. daveylex thread starter macrumors newbie

    Joined:
    Aug 8, 2009
    #7
    Okay downloading it now - hopefully it will work.

    One question though, after installing the driver - will the Direct features like DirectDraw, Direct3D Acceleration become 'Available'? Or do I have to download other stuff as well?

    Thanks again.
     
  8. daveylex thread starter macrumors newbie

    Joined:
    Aug 8, 2009
    #8
    Download finished, extracted the files then tried to launch the setup.exe - no luck. It gave me an error stating that;

    'The NVIDIA setup program could not locate any drivers that is compatible with my current hardware'
     
  9. daveylex thread starter macrumors newbie

    Joined:
    Aug 8, 2009
    #9
    Okay I checked the mod inf stuff from the link you gave me which will help me ignore the error message and finally the driver is installed which is .. latest for my GeForce 9400M I believe. But still, no games can be launched and under dxdiag all of the Direct3D, DirectDraw and AGP Texture Acceleration are 'Not Available'.

    Does it have to do with my Direct X? Under dxdiag my Direct X version is 8.1 - though I downloaded DirectX 9 off some websites, it still remain at 8.1 =/

    Come on is there any experts that can help me with this problem? Thanks.
     
  10. Rodus macrumors 6502a

    Rodus

    Joined:
    Oct 25, 2008
    Location:
    Midlands, UK
    #10
    Odd, have you tried upgrading to XP SP3 and see if that helps, there's no reason not to really and that should take DX up to 9.0c
     
  11. daveylex thread starter macrumors newbie

    Joined:
    Aug 8, 2009
    #11
    Okay, I'll try that out when I get home, though I've tried it once before and the whole windows froze whenever I insert the SP3 disc. By the way, don't you need 2.1 Boot camp for SP 3 ?
     
  12. Rodus macrumors 6502a

    Rodus

    Joined:
    Oct 25, 2008
    Location:
    Midlands, UK
    #12
    you can get 2.1 here
    All you need to do in Windows is to Download SP3 from MS's website.
     
  13. daveylex thread starter macrumors newbie

    Joined:
    Aug 8, 2009
    #13
    I have tried installing it before, tried opening and it gave me an error - I will try again later. Thanks for the help.
     
  14. Stridder44 macrumors 68040

    Stridder44

    Joined:
    Mar 24, 2003
    Location:
    California
    #14

    Ugh, why? Laptopvideo2go has NEVER had good drivers. Not to mention all the random versions are confusing and work OK at best. Just get them straight from Nvidia and save yourself the headache.
     
  15. daveylex thread starter macrumors newbie

    Joined:
    Aug 8, 2009
    #15
    Okay just found out the boot camp installed is already version 2.1 ugh... alright so under Nvidia folder inside the OS X disc, there's 2 Nvidia driver installers. One is NvidiaGraphicsMobileXP another is NvidiaGraphicsDesktopXP(which gives me error saying can't locate my drive and is compatible for my hardware). By the way, letting the boot camp install my graphic driver it totally kills everything. It went to 680x520 resolution and 4 bit only - I couldn't do anything but disable it..

    Still need help =/ Already a week with this problem.
     
  16. m4ch1n3 macrumors newbie

    Joined:
    Jul 15, 2009
    #16
    sry .. thought i had a solution but was wrong ...
     
  17. daveylex thread starter macrumors newbie

    Joined:
    Aug 8, 2009
    #17
    I doubt it will work since I'm using an iMac desktop - not notebook... and my Safari/IE has problem with loading the Nvidia pages except that link you gave me =o
     
  18. daveylex thread starter macrumors newbie

    Joined:
    Aug 8, 2009
    #18
    Still need help with installing the correct driver for Nvidia GeForce 9400m..
     
  19. Markov macrumors 6502

    Markov

    Joined:
    May 18, 2007
    Location:
    Philadelphia
    #19
    When you tried installing the graphics drivers from the bootcamp disk, that more than likely uninstalled whatever you had. It is possible that if you ran it again, they would install correctly.

    The SP3 installation error you have is something I have encountered before, except by that time my brother slip streamed SP3 into our XP disk. Your best bet is to try and make an iso from the XP SP2 disk and slip stream SP3. Google slip streaming for doing this.

    Your problem is simple, you need SP3... period.

    Good luck!
     
  20. daveylex thread starter macrumors newbie

    Joined:
    Aug 8, 2009
    #20
    Ah well - I installed a driver which installed and restart my comp - my resolution remains same and then ran the dxdiag. Everything seems fine under the Display>Device, however my Direct3D Acceleration is 'Not Available' and my DirectX version is only 8.1.

    I guess I have to download SP3 off Microsoft since my SP3 disc seems to freeze my computer. Not only my comp but also other PCs I've tried.

    How do I make my Direct3D Acceleration 'Available'? Oh.. and my GTA still fails to run but this time when I click the game launcher - nothing happens lol

    I will post the information from my Display under the dxdiag when I get home.

    Thanks guys. Hopefully it SP3 solves my epic problem.
     
  21. daveylex thread starter macrumors newbie

    Joined:
    Aug 8, 2009
    #21
    Just went back home and checked the dxdiag;

    Card name: NVIDIA GeForce 9400
    Manufacturer: NVIDIA
    Chip type: GeForce 9400
    DAC type: Integrated RAMDAC
    Device ID: Enum\PCI\VEN_10DE&DEV_0867&SUBSYS_00AD106B&REV_B1
    Display Memory: n/a
    Current Mode: 1680 x 1050 (32 bit) (60Hz)
    Monitor: Default Monitor
    Monitor Max Res:
    Driver Name: nv4_disp.dll
    Driver Version: 6.14.11.8585 (English)
    DDI Version: Unknown
    Driver Attributes: Final Retail
    Driver Date/Size: 4/30/2009 22:02:00, 5896320 bytes
    Driver Signed: Yes
    WHQL Date Stamp: n/a
    VDD:
    Mini VDD: nv4_mini.sys
    Mini VDD Date: 4/30/2009 22:02:00, 8055584 bytes
    Device Identifier: {D7B71E3E-4B27-11CF-5252-A62010C2CB35}
    Vendor ID: 0x10DE
    Device ID: 0x0867
    SubSys ID: 0x00AD106B
    Revision ID: 0x00B1
    Registry: OK
    DDraw Status: Not Available
    D3D Status: Not Available
    AGP Status: Not Available

    Downloading SP3 now. Oh and I noticed that when I changed my Windows XP to 16 bit only, the DDraw Status and AGP Status comes back to Available but still no games launched XD
     

Share This Page