OS X Dock, 2D or not 2D......

Discussion in 'macOS' started by Mr.Noisy, Feb 9, 2010.

  1. Mr.Noisy macrumors 65816

    Mr.Noisy

    Joined:
    May 5, 2007
    Location:
    UK™
    #1
    Ok here's the deal, Ive been using the 3D dock since installing Snow Leopard, and fancied a change so tried switching to 2D using candybar, nothing changed :confused: so I opened terminal using the defauls command and nothing happened. Am i missing something, in Leopard it changed like the weather, no problems, but in Snow Leopard it doesn't want to change, not a major issue, but it would be nice to switch to 2D on the bottom for a while.

    thanks in advance of any advice to help ;)
     
  2. VPrime macrumors 68000

    VPrime

    Joined:
    Dec 19, 2008
    Location:
    London Ontario
    #2
    What terminal command are you typing?
    I just tried this and it works in SL.
    Code:
    defaults write com.apple.dock no-glass -boolean YES;
     killall Dock
    
     
  3. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #3
    I use a program called docker to change the dock. It simplifies the change and avoids the need for going into terminal
     
  4. Forsaken macrumors regular

    Forsaken

    Joined:
    Dec 1, 2009
    #4
    If you're just changing it to 2D opening up Terminal isn't going to kill you. Takes only a few seconds.
     
  5. Mr.Noisy thread starter macrumors 65816

    Mr.Noisy

    Joined:
    May 5, 2007
    Location:
    UK™
    #5
    Thanks for the replies guys, tried all these and a few more, works ok on the left or right, but no joy on the bottom :(

    it's starting to hack me off now, started as a mess about, now i really want the 2D dock and it's got to be something simple i'm missing :confused: but what,
    any other idea's greatly appreciated :)
     
  6. Saturn1217 macrumors 6502a

    Joined:
    Apr 28, 2008
    #6
    yeah just using the terminal command works fine for me. It was one of the first things I did after installing snow leopard because I really prefer the 2d dock

    did you type "killall Dock" afterwards (without the quotes)?

    just paste this into the terminal:

    defaults write com.apple.dock no-glass -boolean YES; killall Dock

    that works for me. Sorry if it doesn't help :(

    Oops I see someone already posted this
     
  7. Jayomat macrumors 6502a

    Jayomat

    Joined:
    Jan 10, 2009
  8. mac2x macrumors 65816

    Joined:
    Sep 19, 2009
    #8
    Why would I want to get another application to do something I can do with an application that I already have? :confused: All you are doing is writing to the property list com.apple.dock (~/Library/Preferences). If you have the Xcode tools, you can look at it in Property List Editor, and do the same thing w/o using terminal. But terminal is easier IMHO. :D

    [edit] Actually, PLE is handier after you write the preference because you can check/uncheck boolean options.
     

    Attached Files:

  9. Mr.Noisy thread starter macrumors 65816

    Mr.Noisy

    Joined:
    May 5, 2007
    Location:
    UK™
    #9
    All Sorted thanks guy's :)

    had a few issues to sort out on the os x side of things, had a lot of time on my hands today so i did a clean install of the os, cured all my issue's,
    now running a nice 2D dock, with square corners and arrow indicators thanks to a useful little app called Docker, but the re-install of the OS did prompt me to set up both my email accounts as imap instead of pop and it cleaned out a few unwanted/unused apps so ive freed up some Hard disk space, so some good came of it, Thanks for your time ;)
     

Share This Page