OS X Installation to new SSD not completing

Discussion in 'Mac mini' started by dbacon, Jun 23, 2013.

  1. dbacon macrumors newbie

    Joined:
    Jun 23, 2013
    #1
    I'm a total mac newcomer so apologies if I'm missing something obvious.

    I've just got a new i7 mac mini (convert from windows world) and decided to install an ssd (Samsung 840 Pro) as the main disk for OS etc.

    Worked through the instructions out there and no problems, booted up machine from original hd, formatted/erased the ssd to Mac OS Extended (Journaled) using the Disk Utility.

    I then rebooted the machine into recovery mode using cmd+R and selected to install OS X to the SSD. This takes around an hour and the machine reboots. At this point I'm a bit lost at what I need to do, the install looks as if it hasn't completed - I can see a folder in Finder - OS X Install Data - if I try to open it I get this message The folder "OS X Install Data" can't be opened because you don't have permission to see its contents. The SSD still does not appear in the startup disk list.

    Could this be a permissions from with the new SSD? Any other preparation I should have performed on the SSD before doing the install?

    Again apologies if I'm missing something very obvious, I've searched through the forum and cannot find a solution.
     
  2. toddzrx macrumors 6502a

    toddzrx

    Joined:
    Nov 20, 2012
    #2
    I'm by no means a pro at this type of thing but I have done a couple of SSD installs in which I used Carbon Copy Cloner to clone my (original) HD to an external HD, replace the original HD with a new SSD, and then clone from the external to the now internal SSD. It's worked fine every time for me. The part that really gets my attention with your situation is that it's taking an hour to install OS X onto the SSD: that seams too long to me.
     
  3. dbacon thread starter macrumors newbie

    Joined:
    Jun 23, 2013
    #3
    I tried using CCC to clone my HD directly to the SSD as I saw a few other people suggested - it completes without error but when I try to select the SSD as the system startup disk I get the following:

    You can’t change the startup disk to the selected disk.
    Building boot caches on boot helper partition failed.

    My goal is to have both the HD (for data, etc) and the SSD (for core apps/OS, etc) in the machine.
     
  4. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #4
    Assuming you got all the cables hooked up properly during the install, it sounds like maybe the new SSD is defective.

    You should be able pop a new, blank SSD in and command-r boot to Internet recovery, then format the SSD like you did and then install the OSA. From what you said, you did everything correctly.
     
  5. dbacon thread starter macrumors newbie

    Joined:
    Jun 23, 2013
    #5
    I didn't format again when I started in recovery mode, I'd read warnings not to use the Disk Utility here so avoided it. Should I be formatting at this level rather than when the machine has fully started?
     
  6. Fishrrman macrumors G4

    Joined:
    Feb 20, 2009
    #6
    My suggestions:

    Option 1:
    - Open up the Mini and SWAP THE LOCATIONS of the two drives inside. You want the SSD to go into the location that the factory-installed drive came in.
    - Now, try again.

    Option 2:
    - Get ahold of a USB3/SATA docking station (go to amazon.com and enter "usb sata dock" in the search box and many will appear).
    - Take the SSD drive out and put it into the dock
    - Try a CCC clone to the docked drive first, then do a test boot (to switch boot, restart, as soon as you hear the startup sound hold down the option key and KEEP HOLDING IT DOWN. The startup manager will appear, use the arrow key, tab key or mouse to select the docked SSD, then hit enter)
    - If you get a successful boot from the SSD while in the external dock, re-install it and see how that does for you.

    Option 3:
    - Proceed as in option 2 above, and just leave the SSD in the external dock. It will run fine as an "external boater" at speeds that will be all-but indistinguishable from an internally-installed drive.
     
  7. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #7
    Not sure what you mean by format again? Did you already format the SSD once at some point?

    A new, blank drive of any type will beed to be formatted before the OS can be installed. So just command-t boot the use Disk Util to format to Mac OS Extended then install the OS. Easy as that.

    Not sure what you read about not using Disk Util.
     
  8. chevelleguy3 macrumors regular

    Joined:
    Apr 24, 2013
    Location:
    Mckinney, TX
    #8
    Just curious, did you change the partition map over to GUID partition from Master Boot Record? Drives will usually come by default setup as MBR.
     
  9. k3nch4n macrumors newbie

    Joined:
    Jun 24, 2013
    #9
    Try imaging your start up disk (Hdd that came with the computer) onto your SSD. Worked for me on my 2012 Mac Mini i7

    The out-of-the-box mini will only support the OS it comes with, and higher. So you're trying to use a Mountain Lion Disc, it won't work since it is 10.8.0, instead of whatever ships with your new Mac Mini.
     
  10. dbacon thread starter macrumors newbie

    Joined:
    Jun 23, 2013
    #10
    Thanks everyone for the suggestions, I've tried them all but no joy. I think it's looking like faulty ssd. Sent it back to the retailer...
     

Share This Page