OS X issues

Discussion in 'Mac Basics and Help' started by Aragorn234, Mar 23, 2012.

  1. Aragorn234 macrumors member

    Joined:
    Mar 10, 2012
    Location:
    Melbourne, Australia
    #1
    I am relative new back into the Macs after being a dedicated user of Windows machines.
    I have a 2011 iMac which runs smooth as silk at all times using some intensive applications (Safari, Mail, Photoshop and Lightroom). I upgraded this machine to 8Gb just so it would not hit a limit. I have never seen the Beach Ball on this machine.

    My work place is all Macbook Pros (and a few Airs). When I started less than a year ago I was given an early 2011 Macbook Pro 15. This machine worked well until I started to open lots of applications then I got the Beachball. When Lion came everyone was upgraded to Lion and since then the beach ball is. The MBP has 8Gb of RAM and the system lags terribly.

    I also have this issue where the screen saver activates ramdomly during use. the only fix I can find online advises to delete a file from library\preferences et etc but that does not resolve the issue.

    None of the guys at work know the cause or how to fix (IT department). Do you think a clean install would be the way to go, to get a quick resolution to the issue?
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    Performance Tips For Mac OS X
    System Preferences > Desktop & Screen Saver > Screen Saver
     
  3. MechaSpanky macrumors 6502

    MechaSpanky

    Joined:
    Sep 11, 2007
    #3
    Aragorn234,

    As GGJstudios was hinting at, there are several screen saver settings to choose from under the System Preferences. You can adjust how long the computer is idle before it activates the screen saver and you can also pick a hot corner.

    I'm guessing that you have or someone has set a "hot corner", and when you put your mouse in that corner, it activates the screen saver. If that were the case, it would appear that the screen saver is coming on for no apparent reason and it will come on even when you are using the computer (not idle). It is that or you just have the timer set to an incredibly low number and when you are idle for even a short amount of time, the screen saver comes on.

    MechaSpanky
     
  4. Aragorn234 thread starter macrumors member

    Joined:
    Mar 10, 2012
    Location:
    Melbourne, Australia
    #4
    Thanks for the reply Mecha.
    Hot corners was one of my original thoughts also. I have checked, re checked and triple checked and have no HC active at all. I have set screen saver also and it is not short.

    To give an idea of the random activation.
    Writing a lengthy email. Half way through (while typing) Ss activates. YES goes straight to screen saver. It is a real pain. Might happen once a day or 5 times a day.
     
  5. Velin macrumors 65816

    Velin

    Joined:
    Jul 23, 2008
    Location:
    Hearst Castle
    #5
    If you didn't do a clean Lion install, this could be a source of the problems. I absolutely would back up your data, wipe the drive, and do a clean Lion install, and then reinstall your apps.

    I dislike OS "upgrades." They've been problematic for me, especially Windows, but OS X has had its issues when upgrading. It's why I always do a clean install, period.

    Don't do a Time Machine install. Do it clean from a newly wiped hard drive. I'd bet good money this solves all your issues.
     
  6. Aragorn234 thread starter macrumors member

    Joined:
    Mar 10, 2012
    Location:
    Melbourne, Australia
    #6
    I am think new install. However need to find the time to do it. Might have to do it after work one day.
     
  7. macbook pro i5 macrumors 65816

    macbook pro i5

    Joined:
    May 13, 2011
    Location:
    New Zealand
    #7
    This is my take on this,I was having the EXACT same problems but then i transfered my important data to an external hardrive and did the reinstall on the harddrive and it runs faster then snow leopard:D:D
     

Share This Page