Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

OS X keeps appending "(2)" to computer name

BriMercer

macrumors regular
Original poster
Mar 14, 2010
130
21
Does anyone know how to fix this? A while back OS X started adding a "(2)" to my computer name. (See below.) I've tried deleting the "(2)", I've tried changing the computer's name various times, but the "(2)" always comes back.

Since this computer is the only with this name on my network, I don't understand why it insists on adding a "2".

Does anyone know why it's doing this and how to get rid of it for good?


.
 

Attachments

  • Screen Shot 2014-10-19 at 12.38.56 PM.png
    Screen Shot 2014-10-19 at 12.38.56 PM.png
    26.6 KB · Views: 708

Intell

macrumors P6
Jan 24, 2010
18,902
420
Inside
This is caused by your computer seeing a ghost of itself on your network. You can make it stop by turning off Wake for Network Access in the Energy Saver pref pane. Once off, rename your machine to finish.
 
Comment

atki81

macrumors member
Sep 13, 2014
62
0
This is caused by your computer seeing a ghost of itself on your network. You can make it stop by turning off Wake for Network Access in the Energy Saver pref pane. Once off, rename your machine to finish.

I've tried this but it puts an error next to Find My Mac and Back To Mac in the iCloud Preferences, there's got to be another way to fix this?
 
Comment

RooneySC

macrumors newbie
Oct 18, 2014
26
0
Hanahan, SC
If your router is dual band and both bands share the same ssid then each device on your network exists twice, one for each band. You are seeing the second version of the device. If you disable the 5ghz band I guarantee the (2) will go away....my Apple TV does the same thing. Nothing to worry about. If it bothers you that much, disable the 5ghz band or change its name so it operates as a separate network.
 
Comment

Intell

macrumors P6
Jan 24, 2010
18,902
420
Inside
I've tried this but it puts an error next to Find My Mac and Back To Mac in the iCloud Preferences, there's got to be another way to fix this?

Nope, that's the only way. That or never allow your machine to sleep or shut down.
 
Comment

chrfr

macrumors G4
Jul 11, 2009
10,177
3,893
If your router is dual band and both bands share the same ssid then each device on your network exists twice, one for each band. You are seeing the second version of the device. If you disable the 5ghz band I guarantee the (2) will go away....my Apple TV does the same thing. Nothing to worry about. If it bothers you that much, disable the 5ghz band or change its name so it operates as a separate network.

I have separate 5 and 2.4GHz networks and my Apple TVs and one Mac append numbers to the name, so it's not purely related to that. In fact, one Apple TV is wired.
 
Comment

ThirtyNine

macrumors newbie
Oct 20, 2014
1
0
Had the same problem with my iMac which was connected to the router via an ethernet cable and by wifi. I turned off wifi and the problem seems to have resolved itself.
 
Comment

netnothing

macrumors 68040
Mar 13, 2007
3,697
317
NH
Had this issue with my MBA.....but.....I believe it's because I was troubleshooting a network issue and plugged it in via Thunderbolt Ethernet. I think the 2nd network connection caused the name to change.

-Kevin
 
Comment

izzle22

macrumors 6502a
Jul 13, 2004
825
170
Kansas City, MO
Me neither. It's frustrating and I can't find any correlation to when it happens. I'm hoping tomorrow's 8.1 updates fix it.

Hopefully you're kidding because IOS will have nothing at all to do with your MacBook adding a number to it's name.
 
Comment

chrfr

macrumors G4
Jul 11, 2009
10,177
3,893
Hopefully you're kidding because IOS will have nothing at all to do with your MacBook adding a number to it's name.

Not necessarily true. Apple TVs run a Bonjour sleep proxy, which may be the cause of the problem. The ATV should not be running the proxy if there's an Airport or Time Capsule already doing it, but there's definitely a bug somewhere in the network naming, and it seems related to wake/sleep.

http://support.apple.com/kb/ht3774
 
Comment

x34

macrumors 6502a
Oct 19, 2014
562
334
This is caused by your computer seeing a ghost of itself on your network. You can make it stop by turning off Wake for Network Access in the Energy Saver pref pane. Once off, rename your machine to finish.

thanks. this seems to solve it.
 
Comment

houssein31

macrumors regular
Jul 16, 2013
147
0
This is caused by your computer seeing a ghost of itself on your network. You can make it stop by turning off Wake for Network Access in the Energy Saver pref pane. Once off, rename your machine to finish.

THANK YOU!!!!! been happening for me 2 and now it fixed
 
Comment

mikecwest

macrumors 65816
Jul 7, 2013
1,046
400
Does anyone know how to fix this? A while back OS X started adding a "(2)" to my computer name. (See below.) I've tried deleting the "(2)", I've tried changing the computer's name various times, but the "(2)" always comes back.

Since this computer is the only with this name on my network, I don't understand why it insists on adding a "2".

Does anyone know why it's doing this and how to get rid of it for good?


.

I fixed this by going into NETWORK PREFERENCES and changing the name of my Location to the name of my computer.

I found the fix on an Apple Forum.
 
Comment

netnothing

macrumors 68040
Mar 13, 2007
3,697
317
NH
Had this issue with my MBA.....but.....I believe it's because I was troubleshooting a network issue and plugged it in via Thunderbolt Ethernet. I think the 2nd network connection caused the name to change.

-Kevin

Take back what I said.....I'm up to #4 on my MBA with no rhyme or reason!

-Kevin
 
Comment

fisherking

macrumors 604
Jul 16, 2010
7,542
2,396
ny somewhere
This is caused by your computer seeing a ghost of itself on your network. You can make it stop by turning off Wake for Network Access in the Energy Saver pref pane. Once off, rename your machine to finish.

this worked for me (or has, so far...) :cool:
 
Comment

AlanShutko

macrumors 6502a
Jun 2, 2008
749
132
Not necessarily true. Apple TVs run a Bonjour sleep proxy, which may be the cause of the problem. The ATV should not be running the proxy if there's an Airport or Time Capsule already doing it, but there's definitely a bug somewhere in the network naming, and it seems related to wake/sleep.

http://support.apple.com/kb/ht3774

The sleep proxy protocol allows multiple sleep proxies on the network. In fact, most recent Macs also run their own built-in sleep proxy (dependent on something in the wifi chipset, I believe). I'm pretty sure this is a Yosemite bug.

My temp fix is a keyboard maestro action on wake that resets my computer name.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.