OS X Leopard-Unable to Archive & Install-Hard Drive Error

Discussion in 'macOS' started by markw10, Nov 28, 2009.

  1. markw10 macrumors 6502

    Joined:
    Sep 4, 2006
    #1
    I am trying to do an archive and Install of OS X Leopard on a MBP but the installer won't allow me to do this.
    I have tried the install by holding down the Option Key at bootup with the Leopard DVD in the drive. I follow all the options and then try to do an Archive and Install but when it gets to the screen with the Hard Drive icon it shows the Hard Drive icon with the Exclamation point in the yellow color. If I select options it tells me I have to erase the hard drive and do a fresh install of OS X.
    I have also tried the install by booting into OS X and then selecting the OS X DVD icon and going through the same steps.
    I have used Disk Utility and done both a verify and verify permissions but no errors at all are found. One odd issue is when I hold down the Option key at bootup it actually lists my internal hard drive twice. It appears everything is fine. Disk Utility finds now errors, shows it has the GUID partition table, and is formatted with OS X Journaled.

    What started all of this is a couple weeks ago I started having Wi-Fi issues. Anywhere I connect to Wi-Fi it connects with the signal but I don't have internet. I'm not able to use Firefox, Safari, or Apple Mail. I posted earlier about this but was unable to fix this problem so eventually went to the Apple Genius Bar. They thought it was a simple issue and tried a couple procedures to renew IP or something like that and restoring some files. After none of that worked the guy then said it's something deeper in the OS and a Archive & Install is the best way to solve it.
    When he tried this though it didn't work. He did a Verify in Disk Utility and found some hard drive errors so corrected them. Once this was done he did another Archive & Install and ran into the same problems I encountered.

    Of course I'm still having this issue. His suggestion was to do the erase and said to first plug in my Time Machine Hard Drive, Do a Backup now, do the erase on the Hard Drive and reinstall Leopard, then he said Time Machine should prompt me to restore or something like that and will copy over all my stuff, documents, itunes music, dock settings, desktop, etc. Basically everything to put my computer back to where it was before. Now I do have a SuperDuper backup but since this is a mirror of the internal hard drive he said it would likely copy the problem back to my internal hard drive.

    Is there a way to possibly do an archive & install? I prefer to go this route but don't know why it won't let me do it. If not, would the above suggested option with Time Machine solve this problem and would I lose any settings or data?

    Another option I may try is I have Leopard on the Machine but have bought Snow Leopard. I haven't done the upgrade because one program I have, PGP, is not Snow Loepard compatible until the next version comes out. Since I haven't used PGP yet if necessary I am willing to uninstall it and install Snow Leopard but i'm not sure if the Snow Leopard upgrade will work and solve the Wi-Fi issue.

    Thank you for your help.
     
  2. waterplant macrumors newbie

    Joined:
    Nov 27, 2009
    #2
    may i ask ? what is your current os ? such as 10.5 or 10.6
    as far as i know if you want to install the os that under with current version
    the system won't install it , because your current os is higher than that disk you want to installed
    for example your system using 10.6 and you planning to install 10.6
    in case the system won't install it because your system is in the current os
    is this help for you ?
     
  3. markw10 thread starter macrumors 6502

    Joined:
    Sep 4, 2006
    #3
    Thank you for your reply. I have 10.5 currently but have already purchased Snow Leopard and tried to install Snow Leopard and have the same issue. It seems for some reason it doen't like something about the hard drive so only wants to give me the option to erase and do a fresh install. When I use Disk Utility it's not finding any errors though.
     
  4. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #4
    Odds are that, if you erase the internal drive then "clone the clone" with SuperDuper, you will get rid of the problem rather than copy it over. Worst case, the drive itself is failing, and you'll have the same problem - if that's what happens, you'll need to get the internal drive replaced.
     
  5. markw10 thread starter macrumors 6502

    Joined:
    Sep 4, 2006
    #5
    What you said makes sense. I assume after cloning the drive I'd simply reformat it and then copy the clone back.
    I believe like you said that it will take care of the issue I'm having. I think it's something related to the boot sector but I could be wrong.
    Would it likely copy back the problem I'm having with Wi-Fi. This would all help me some though because now I'm unable to do an archive & install and at least this way I would then be able to do that or even do a SuperDuper update.
     

Share This Page