OS X Lion Accented Characters

Discussion in 'Mac OS X Lion (10.7)' started by windowstomac, Oct 20, 2011.

  1. windowstomac macrumors regular

    Joined:
    Jun 23, 2011
    #1
    Lion has a new feature where you can input accented letters by holding down the relevant key - i.e. hold down "e" and you get a little menu with all e's with different accents.

    Trouble is, I live in Portugal and have a MBP with a Portuguese keyboard. When I am set to that layout, the menu doesn't appear...if I switch to English (which I have as an option so I can type pound signs) the accent menu DOES work.

    Does anyone know a way / terminal hack to that I can get the accent menu to appear when I am using the Portuguese language? I don't want to leave it set to English all the time because then all my symbols are in the wrong place, and I have only just got used to the Portuguese layout!

    many thanks
     
  2. miles01110 macrumors Core

    miles01110

    Joined:
    Jul 24, 2006
    Location:
    The Ivory Tower (I'm not coming down)
    #2
    With foreign layouts you generally have dedicated accent keys... why do you need the menu when you have dedicated keys?
     
  3. windowstomac thread starter macrumors regular

    Joined:
    Jun 23, 2011
    #3
    The thing is all there is on a PT keyboard is çÇ , no accented a's or e's, which I need all the time....
     
  4. miles01110 macrumors Core

    miles01110

    Joined:
    Jul 24, 2006
    Location:
    The Ivory Tower (I'm not coming down)
    #4
    But isn't there a dedicated accent key? You hit the accent key and then the letter you want to accent. On my Swiss French keyboard that's how it works.
     
  5. windowstomac thread starter macrumors regular

    Joined:
    Jun 23, 2011
    #5
    Oooh, perhaps I missed that, it's my first non-English laptop! What does the key look like?
     
  6. miles01110 macrumors Core

    miles01110

    Joined:
    Jul 24, 2006
    Location:
    The Ivory Tower (I'm not coming down)
    #6
    [​IMG]

    It's probably the one to the left of the Enter key. You either press it or combine with the shift key to get which accent you want. The acecnt will appear highlighted and then you press the letter you want to be accented.
     
  7. Patrick J macrumors 65816

    Patrick J

    Joined:
    Mar 12, 2009
    Location:
    Oporto, Portugal
    #7
    I have a Portuguese keyboard.

    Hit the key between the ª,º key and the enter key. After that, hit an a, e, i, o, or u. áéíóúàèìòù.
     
  8. windowstomac thread starter macrumors regular

    Joined:
    Jun 23, 2011
    #8
    You learn something every day! Thank you very much!
     
  9. tkermit macrumors 68030

    tkermit

    Joined:
    Feb 20, 2004
    #9
    That sounds like a bug. You should report it!
     
  10. windowstomac thread starter macrumors regular

    Joined:
    Jun 23, 2011
    #10
    I agree. Although thanks to the people here I now have another way, I would rather like the new feature to work when the language setting is set to Portuguese.
     
  11. Franciturci macrumors member

    Joined:
    Oct 7, 2009
    #11
    I have tested : it's really odd,

    It works for :
    • english
    • italian
    • french
    • romanian
    • greek
    • dutch
    • ...

    It doesn't work for :
    • portuguese
    • polish
    • welsh
    • bulgarian

    and maybe others. So it's definitely an important bug...
     

Share This Page