OS X Lion: Speaker Grayed Out Workaround

Discussion in 'Mac Basics and Help' started by Hyper-X, Aug 15, 2011.

  1. Hyper-X, Aug 15, 2011
    Last edited: Aug 27, 2011

    Hyper-X macrumors 6502a

    Jul 1, 2011
    This is a problem that appears on many OS X Lion machines where the speaker icon on the menu bar randomly or consistently grays itself out. The most common solutions are to plug in/out a headphone into the jack or opening up Terminal and typing "sudo killall coreaudiod" which can be cumbersome and annoying to do.

    The following steps will accomplish the same results as the above automatically without your intervention. If you prefer to do this on a case-by-case situation, go all the way down to the end of this post and you'll find Kai Yen's simple app that you can click on to restart the coreaudiod process. His app will ask you for your login password each time you use it.

    Problem: Computer shows the speaker icon grayed out randomly or consistently after you installed/upgraded to Lion.

    Cause: Still unsure as to what's causing this. I've read numerous posts about how it could be associated to the Audio Midi Setup, PRAM, Disk Permissions, Audio Folders and I'm still uncertain as to what's causing the problem. All I can say is nothing has worked consistently until this workaround. We all know that stopping the coreaudiod process is a temp fix, but it's annoying to always having to do this.

    Workaround Procedure:

    1. Open Utility.

    2. Open Applescript Editor.

    3. Copy the following and paste it at the top half of the editor: (copy everything below with the quotes in place)

    do shell script "launchctl stop com.apple.audio.coreaudiod" password "your_password" with administrator privileges

    4. Replace "your_password" with your login password. For example if your login password is ILOVEMYSON2011 then it should look like...

    do shell script "launchctl stop com.apple.audio.coreaudiod" password "ILOVEMYSON2011" with administrator privileges

    NOTE: What this does is it'll accomplish the same thing as "sudo killall coreaudiod" without you having to open Terminal and typing it all the time. This will automatically run each time you start your machine. This means it will NOT ask you for your password when it runs.

    5. Now go to File ---> Save As (in the Applescript Editor on the Menu Bar)

    Now choose a name for the file after "Save As". I called mine "AudioFix"

    Under "File Format", choose "Application".

    Save it to your Desktop for easy finding. You can move it elsewhere later.

    6. At this time if you want to put the app you just made elsewhere, like in Applications or wherever you want, do so now.

    7. Open System Preferences --> Users and Groups.

    8. Select "Login Items".

    9. Click on the "+" icon, which is the "Add an item to the Login Items list."

    10. Find the application you just made. I put mine in the Applications folder.

    That's it. Now each time you boot up or restart your machine, Lion will run this app and restart the coreaudiod process. Now pray that Apple comes out with a real, official fix.

    After a bit of searching, I found a neat app made by Kai Yen which simply executes "sudo killall coreaudiod" in the form of an app. You can put it in your Applications folder then drag it to your dock to run as you need. If you want to have it run during Login, simply follow Steps #7-10.

    The difference here is every time the app runs, it will ask you for your login password. This is good for those who are concerned/worried about storing any password on your computer associated with your login.

  2. Aubianne macrumors newbie

    Aug 26, 2011
    A thousand times, thank you!


    Not that I have such days, but if I did, today would be one where I wished I was a prostitute, so that I could show you just how grateful I am for this.

    Thank you, thank you, THANK YOU. Being that my ENTIRE project is audio-based (an audio drama) you can imagine how wonderful it is to lose iTunes, or YouTube, or even VLC - and not for any known reason, either. No, no. Just because.

    I am indebted to you.

    As for you, Apple -- really, guys? Please! Get on this! I get that all new releases have bugs, but this is ridiculous.

  3. couto27 macrumors 6502

    Nov 10, 2008
  4. teobesta macrumors newbie

    Oct 2, 2011
    thank you a million times over

    had found the kai yen solution via twitter
    but it hadn't worked for me

    i wish i'd found this post first
    would've saved me *hours*
  5. kalakov macrumors member

    Apr 4, 2011


    great work hyper-x
  6. east69 macrumors newbie

    Oct 15, 2011
    Hrt music streamer pro

    Tried anything but it seems not to work on my machine. You think there might be a difference within the streamer models? I use a HRT Music Streamer Pro Model. Really sad that I can't listen to all the good music anymore.... ...also the latest Apple fix seems not to work anymore...

    really help needed


  7. Mr.Wang macrumors newbie

    Oct 15, 2011
    If you don't want your password to be saved in applescript, just click on the check-box "run-only" when saving it. The file will not be editable and cannot be opened later on.
  8. neurophysicist, Nov 11, 2011
    Last edited: Nov 11, 2011

    neurophysicist macrumors member

    Jul 20, 2011
    Hello everyone,

    I was still having some trouble. I used Hyper-Xs suggestion to make the script. When it is run, the grey half circles next to the speaker button disappear, but then they come back again later. Did anyone else still have trouble with this?

    EDIT: Tried restarting and such, still the same problem. Only way to work around at the moment is headphones :cool:. Also downloaded the app made by Kai Yen, same thing happens.
  9. neurophysicist macrumors member

    Jul 20, 2011
    After shutting down, audio worked most of today. However it has now gone out again after using quicktime to watch a movie. Anyone else have something similar happen?:(
  10. Hyper-X thread starter macrumors 6502a

    Jul 1, 2011
    What you're seeing is relating to reseting the "coreaudiod" process. If you type in Terminal ""sudo killall coreaudiod" without the quotes, it accomplishes the same thing, just in a different way.

    Think of it like rebooting just the audio portion. Running the script shuts down the processes and OS X simply restarts them.

    This workaround is very specific to a type of audio problem, it doesn't fix all audio-related issues.

    It's possible you might have an issue with Lion and the Audio Mixer settings. You can take a look at the following link.

  11. danzg macrumors newbie

    Oct 31, 2010
    Does anyone know if this has been fixed yet??
  12. Hyper-X thread starter macrumors 6502a

    Jul 1, 2011
    Need someone to verify if this exists in 10.7.4, thanks.
  13. Gi0 macrumors newbie

    Jun 1, 2012
    10.7.4 and just got this problem.MBP mid 2010.
    One hint that might help. I used QuickTime after a long time (vlc user) just before it appeared. Script and app are no go, only workaround is to plug in the headphones:mad:
  14. Gi0 macrumors newbie

    Jun 1, 2012
    Quick and dirty fix (..at least for my case).
    Watched the video i was watching when the problem occured with plugged in earphones. But this time i watched it till the end, let quicktime finish its thing with the sound (something that i hadn't done when the whole thing started).Removed earphones after and everything seems to work ok. Restarted a couple of times without any problem.
    Won't be using quicktime any time soon.
  15. Hyper-X thread starter macrumors 6502a

    Jul 1, 2011
    Your symptoms don't seem to match up with the conditions of this workaround. The workaround is a script to automate the process of killing a specific process so that OSX can reload it, thus restoring sound.

    Your situation appears to be linked to a specific app (QT) using ear/headphones and it's possible you're suffering from a different issue. I posted this link above but if you haven't seen it yet, here it is again.


  16. johannnn macrumors 65816


    Nov 20, 2009
    Have this issue on brand new MBA on Mavericks after playing Youtube in Safari sometimes. The shell script worked wonderfully, thanks!

Share This Page