OS X Lions isn't booting properly after installing rEFIt

Discussion in 'Mac OS X Lion (10.7)' started by sclomps, Oct 1, 2011.

  1. sclomps macrumors newbie

    Joined:
    Mar 7, 2011
    #1
    A few days ago I installed rEFIt 1.4 because I was going to install Windows 7 on my MBP.
    The installation was ok but when I try to boot to Lion (currently the only OS) I get a screen with the Apple logo and a spinning wheel and I doesn't boot. Then I have to hold down the power button until the MBP is powered of and try again to boot and it's only then that I can boot into Lion.
    I have tried uninstalling and reinstalling rEFIt but it didn't work so, what can I do to solve my problem?

    Thank you very much for our attention
     
  2. softwater macrumors newbie

    Joined:
    Dec 3, 2010
    Location:
    Thailand
    #2
    Did you try uninstalling rEfit and installing it again while booted into Snow Leopard rather than Lion?
     
  3. sclomps thread starter macrumors newbie

    Joined:
    Mar 7, 2011
    #3
    I don't have Snow Leopard installed anymore but I think I've solved the problem uninstalling rEFIt.

    Thanks for your help
     
  4. IVoidWarranties macrumors newbie

    Joined:
    Nov 1, 2011
    #4
    hmm

    Hello all...

    Ive been fighting with my MBP for about two weeks now trying to get Lion and Windows 7 to work.. well let me rephrase, getting rEFit to work with lion.. I had it dual booted with rEFit and Snow Leopard for months since i bought it no problem, but i've reformatted at least 10 times now and can't seem to get it working. I get the same apple logo and hanging spinny thing every time. Tried reinstalling rEFit a bunch of times, nothing. I'm new to Mac but have a lot of experience with PC's so if any solutions involve Terminal im all for it but please explain thoroughly :) Any ideas???

    I'm ready to just go back to SL and 7 and say F&%k you lion even though I paid the $30, seems to run slower than SL anyway. I need to get this fixed soon though i need to move to the cloud i use mobileme to keep track of all my calanders for work..

    any help greatly appreciated..
     
  5. pier macrumors 6502

    pier

    Joined:
    Feb 7, 2009
    #5
    Anyone found a solution to this?

    I uninstalled rEFIT and half of the times I can't boot in Lion, or when I can it takes a LOT. Before rEFIT I booted into Lion in about 20-30 seconds, now it takes like 2 minutes.

    :mad:
     
  6. ewv macrumors newbie

    Joined:
    Sep 21, 2010
    #6
    the instructions for manual install worked fine for me without issue

    Download the “Mac disk image” or any of the other two binary distributions from the home page. Double-click to mount or unpack them.
    Copy the “efi” folder from the rEFIt distribution to the root level of your Mac OS X volume. (Macintosh HD)
    Open Terminal and enter the following commands:

    cd /efi/refit
    ./enable.sh

    When prompted, enter the password for your user account.
     

Share This Page