os x Mavericks cannot be installed on this computer...

Discussion in 'OS X Mavericks (10.9)' started by Killerbob, Oct 11, 2014.

  1. Killerbob macrumors 6502a

    Joined:
    Jan 25, 2008
    #1
    I have tried a number of times to get this very annoying message. It is especially irritating becuase I know I can install Mavericks on the particular laptops I get the message on...

    A MacBook Air toasted on me, and I took out my USB stick with 10.9.3 and booted it up. I used Disk Utility to erase the partition and create a new one. I then tried to reinstall OSX but got the message "os x Mavericks cannot be installed on this computer". Of course it is BS, as the MBA had Mavericks on it before. I eventually got on by using internet recovery.

    I just had the same thing happen to me on a MacBook Pro. A MBP which had Mavericks installed and working before I decided to repartition it.

    What is going on??? Am I doing something which isn't possible, or what. I have used the USB installation method many times...
     
  2. 53kyle macrumors 65816

    53kyle

    Joined:
    Mar 27, 2012
    Location:
    Sebastopol, CA
    #2
    It sounds like your install USB is corrupted, so re-download the installer from the mac app store and make a new one.
     
  3. Killerbob thread starter macrumors 6502a

    Joined:
    Jan 25, 2008
    #3
    Yes, I thought so too. But, I have tried this with three different USB keys. Two created using X-Disc, and one using the

    sudo /Applications/Install\ OS\ X\ Mavericks.app/Contents/Resources/createinstallmedia --volume /Volumes/Untitled --applicationpath /Applications/Install\ OS\ X\ Mavericks.app --nointeraction
     
  4. yjchua95 macrumors 604

    Joined:
    Apr 23, 2011
    Location:
    GVA, KUL, MEL (current), ZQN
    #4
    The USB key isn't the problem. It's the installer app itself that's corrupted.

    Download a new one off the Mac App Store.
     

Share This Page