OS X Mavericks wakes my Mac from sleep every hour or so

Discussion in 'OS X Mavericks (10.9)' started by Gary King, Oct 29, 2013.

  1. Gary King, Oct 29, 2013
    Last edited: Oct 29, 2013

    Gary King macrumors 6502

    Joined:
    Jun 14, 2004
    #1
    Ever since upgrading to Mavericks, it looks like my Mac Mini wakes from sleep about once an hour or so. In the Console, I get the following message:

    Oct 30 02:12:06 gary-mac WindowServer[93]: CGXDisplayDidWakeNotification [89885620192550]: posting kCGSDisplayDidWake
    Oct 30 02:12:06 gary-mac WindowServer[93]: handle_will_sleep_auth_and_shield_windows: Deferring.

    Anyone know why it's doing this?

    Usually when the computer wakes from sleep, whether manually or automatically, there is a "Wake Reason" line, but in this case there isn't one. My guess is that this is because since Mavericks, "Sleep" doesn't actually put the Mini to sleep. It seems to be more "on" than it used to be. Is there a way to revert the behavior to how it was before Mavericks?
     
  2. matthewadams macrumors regular

    Joined:
    Dec 6, 2012
    #2
    You could go ahead and try to find out by opening the terminal and enter
    pmset -g log that might give you some detailed insight into why your mac is waking up.
     
  3. Macman45 macrumors demi-god

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #3
    I thought this had ben cleared up in Mavericks...It was well known in ML. First thing to do is to check your activity monitor to see what's running...If that's clean, then I guess the instructions in the link to my old post will still work, preventing the Mac from hibernating, but I re-set mine and it hasn't done this since Mavericks was installed.

    The old thread link :

    http://forums.macrumors.com/showthread.php?t=1529750

    There does seem to be few newer postings in there, but my bet would still be on something running that's causing this..."Wake for Network access" may be ticked etc. I'd do a little digging before using Terminal commands to prevent hibernation.
     
  4. mzd macrumors 6502a

    Joined:
    Jul 25, 2005
    Location:
    Wisconsin
    #4
    happening to me too. every hour or so, all my drives spin up (including external and superdrive). my display doesn't light up, but there is definitely something interrupting the sleep.
    this did happen to me a long time ago (can't remember for sure which version of OSX but definitely pre-Lion) but i haven't had the problem in years until the Mavericks update.
    i'll run that terminal command and see what is in the logs...
     
  5. Gary King thread starter macrumors 6502

    Joined:
    Jun 14, 2004
    #5
    Yes indeed, every hour my external drives spin up, but my display remains asleep. I have two USB external drives, and they are louder than my Mac Mini (because it has an SSD), so that's how I know it keeps waking up. Frankly if I didn't have external drives, I probably wouldn't notice the problem, then I wouldn't care.

    I had this problem about a month ago when OS X 10.8.4 or 10.8.5 was released, because it didn't properly sleep external drives. They fixed it a few weeks ago, but it looks like a similar problem is back now in Mavericks.
     
  6. Asrath macrumors newbie

    Asrath

    Joined:
    Oct 8, 2013
    #6
    Same here. I noticed that my mavericks installation set new parameters in some preferences. Check your energy saving preferences. Is your Mac configured to wake on incoming network traffic? As I don't have an English system I can't tell you the correct phrase for this setting.
    Anyway, since turning that off, my Mac sleeps well again. And so do I.
     
  7. natd1993 macrumors regular

    natd1993

    Joined:
    Jul 6, 2011
    Location:
    UK
    #7
    Turning off 'wake for network access' in the energy saver preference pane solved this for me.
     
  8. Gary King thread starter macrumors 6502

    Joined:
    Jun 14, 2004
    #8
    I have always had "Wake for network access" OFF for me, and still have it off. So no, that is not the problem in my case.
     
  9. Macman45 macrumors demi-god

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #9
    In that case, run the terminal commands in the link I posted above. Your Mac will still sleep, it just won't hibernate...That's how we solved it under ML and it worked fine. To re-instate hibernation at any time should you wish to, just replace the zeros in the commands with ones.
     
  10. AeroZ macrumors 6502

    AeroZ

    Joined:
    Aug 7, 2013
    Location:
    Estonia
    #10
    What's the difference between autopoweroff and standby? And what's the difference between autopoweroffdelay and standbydelay? Seems like the same thing
     
  11. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #11
    It sounds like you have Powernap turned on. Look in the Energy Saver System Pref to see if it is on. Powernap checks Mail etc hourly when even when the system is asleep.
     
  12. Gary King thread starter macrumors 6502

    Joined:
    Jun 14, 2004
    #12
    I have Power Nap disabled. I have everything on the Energy Saver page unchecked.
     
  13. Gary King thread starter macrumors 6502

    Joined:
    Jun 14, 2004
    #13
    Turns out it's because I had "File sharing" enabled on my "Sharing" Preferences pane. This prevents Mavericks from sleeping. However, this did NOT prevent any OS before Mavericks from sleeping, which leads me to believe this may be a bug in Mavericks. I'll have to disable File sharing before I sleep my Mac now.

    Also, "pmset -g assertions" is what ultimately helped me find the problem, which was due to "com.apple.smbd" that was causing "DenySystemSleep".
     
  14. corrr macrumors newbie

    Joined:
    Feb 2, 2014
    #14
    same problem, but only when sharing to windows clients

    I see this thread is already a bit outdated, but I have the same problem, and can't seem to fix it.

    My mac mini also stays awake when samba sharing is turned on in Mavericks. But it only has this problem when i enable sharing to (at least one) windows user.

    If I (samba)share to macs only, it just goes to sleep after the time set in energy preferences (and wakes up when file access is needed). I have afp disabled, so i know it's using smb, even when other macs connect.

    It's really annoying, because i only need to access it maybe once a day from a windows computer. Now my mac mini needs to stay awake all the time, just for that.

    In what way does sharing to windows computers change the behaviour of the samba daemon?

    Does anyone have a solution to this?
     
  15. leventozler macrumors 6502

    Joined:
    Feb 18, 2009
    #15
    Dealing with the same problem. If you use smb2 (connect from Mavericks) com.apple.smbd stays active (even after disconnecting) and prevents sleep. If you use cifs:// (smb1) and unmount, com.apple.smbd dissapears.
     
  16. leventozler macrumors 6502

    Joined:
    Feb 18, 2009
  17. Bart H macrumors newbie

    Joined:
    Nov 25, 2012
    Location:
    Central Virginia
    #17
    Wake for Network Access

    Someone above mentioned this setting. I updated from SL to ML last year and noted the absence of this setting in its usual place. It does not seem to be in Mavericks either.

    I had always thought this would prevent unwanted intrusions, for example, overnight. Was I wrong and it was removed due to being ineffective, or is it now somewhere else?

    Thanks,
    Bart
     
  18. Gary King thread starter macrumors 6502

    Joined:
    Jun 14, 2004
    #18
    Can you specify which problem it fixes? The fact that the Mac wakes from sleep when File Sharing is enabled?
     
  19. Alrescha macrumors 68020

    Joined:
    Jan 1, 2008
    #19
    I think it works like this:

    If you have something enabled in Sharing, and you have Wake for network access enabled, and there is a Bonjour Sleep Proxy available (Apple TV, Airport, etc.), then your Mac will wake up every two hours or so to refresh the proxy with its state. If you do not have Wake for network access enabled, this should not be happening and hopefully is fixed in 10.9.2.

    A.
     
  20. Gochugogi macrumors regular

    Gochugogi

    Joined:
    Oct 27, 2013
    Location:
    Sandwich Isles
    #20
    Ditto. Not sure why it was rechecked after the 10.92 update but it was.
     

Share This Page