OS X Mavericks Wireless Issues

Discussion in 'Mac Basics and Help' started by Jameslr2015, Feb 9, 2014.

  1. Jameslr2015 macrumors newbie

    Joined:
    Oct 16, 2013
    Location:
    Oklahoma City, OK
    #1
    Okay, so I have searched the web for about two full weeks trying to find a solution to this particular issue. Needless to say I have found none. I recently moved out of my parents house and so I have a new wireless environment. I am using a new router running Firmware: "DD-WRT v24-sp2" My father gave me this router and he was the one that flashed the third party firmware on it. Needless to say I despise it.

    My issue is this, my iMac is upstairs the router downstairs. I am still getting about 45% fair connection. The router states this. About every so often sometimes within seconds my internet drops on my Mac. OS X says it still has an established connection with the router but the ISP, Server, and Internet have failed to connect. Turning WiFi off and back on seems to temporarily fix the problem; however, I have to do this sometimes 3-5 times in less than five minutes because it keeps cutting out. I have tried a bunch of different settings from: Setting Static IP on my Mac, to setting the router from Mixed to only 2.4GHz N. Nothing seems to fix the issue. I even set the security to WP2 AES encryption, NAT Open, Mac Address Filtering Off, and DHCP Auto ON, which is what Apple recommends on the website. It's still being a nuisance and I end up using my iPhone more than my Mac. I am getting very tired of this issue and if anyone has any magical advice please let me know!

    27-Inch, Mid 2011 iMac OS X 10.9.1 (13B42)
     
  2. smithrh macrumors 68020

    smithrh

    Joined:
    Feb 28, 2009
    #2
    Honestly it sounds like the router is flakey.

    Take a look at your DHCP renewal time on the router, it may be set to something abnormally low - like 60 seconds instead of 60 minutes.
     
  3. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #3
    1. Reset NVRAM / PRAMM.


    2. Turn off wireless. Go into the application /Applications/Utilities/Keychain Access and find the entry for your non-working setting and delete it. Then turn your Airport card back on and rejoin your wireless network.


    3. Open System preferences->Network pane, Advanced button and click on the 'Renew DHCP Lease' and see if you get all the network settings, including the 'DNS' mini-tab. If you get no DNS settings use either OpenDNS or Google Public DNS and put those IPS in the DNS mini-tab.


    4. Staying in the System Preferences->Network pane, at the top of that pane is the 'Location' pull-down. Use that to select 'EditLocations …' and in the pop-out click on the + symbol to add a new custom named Location (calling it what you like) and then saving that in the pop-out, Network main page. Don't worry because it will act the same as 'Automatic', you just giving it a custom name. Then Use the System Preferences->Network pane, Airport card to rejoin your wireless network.


    5. Turn off the wireless card. Then open Finder window and go to the folder /Library/Preferences/SystemConfiguration/ and move the files com.apple.airport.preferences.plist & NetworkInterfaces.plist to your desktop. Then IMMEDIATELY REBOOT!!!


    This reboot will rebuild fresh Preferences in that folder. Upon the reboot go back into System Preferences->Network page and male sure all you networking devices are put back in. If any are missing network port you can use the + button, in the Network System Preferences pane, and add the port back into your Macs Network setup. Then from that pane select you Airport card and from there use that Network pane to rejoin your wireless network. Lastly if everything is working, throw out those files you moved to the desktop out.


    6. In your wireless router go back to System Preferences->Network pane and click on the 'Advanced' button, Hardware ini-tab and set your MTU settings back down from 1500 to 1453. Some older wireless routers seem not to be able to do Jumbo frames (the 1500 MTU settings). It is hit or miss in the hint.


    7. Reset your wireless router. If you never been in your wireless router, get the default router password visit the web site Router passwords.com to get the default username/password. This way you can reset your wireless router.
     
  4. Jameslr2015 thread starter macrumors newbie

    Joined:
    Oct 16, 2013
    Location:
    Oklahoma City, OK
    #4
    Problem Solved. I Think...

    Well, after some painful moments I did what everyone said. I my own thing too. I updated the routers firmware and it worked but was not broadcasting a wireless System Set Identifier SSID, so I plugged the stupid thing into the ethernet port and re-flashed the old firmware on it. Turns out that did something. How, I have no idea, it stopped kicking me off. The security is now set to TKIP rather than AES how this makes any difference I don't know as Apple recommends AES Encryption of the packets. Now as far as I understand AES is a higher strength encryption so maybe it takes less information since the router is far away? Correct me if I am wrong. My junkie roommate has a god complex with networking and said this although I read that TKIP is a heavier encryption as it assigns an individual key to each packet basically fixing what AES lacks. I don't know, as my first post on MacRumors I want to thank you all for the help!
     

Share This Page