OS X reports disk full and won't start

Discussion in 'macOS' started by Mad Pierre, Jan 14, 2011.

  1. Mad Pierre macrumors newbie

    Mad Pierre

    Joined:
    Jan 6, 2009
    #1
    I ran SuperDuper last night and the backup failed with an unknown error. After, Spotlight didn't find files. I rebooted and at the login screen was given the error message 'backup disc full, delete some files' - problem is, OS X won't boot beyond the starfield screen, so there's no way of deleting files or running the system. I took the drive out and put it in a USB caddy on another machine and ran Disk Utility - it said repairs were needed, so I did this. However, putting it back into the MBP nothing has changed, it still won't boot and insists the disc is full - there is over 180GB free! (I can see this when I mount it on another machine.) Ideas?!
     
  2. Mactrillionaire macrumors regular

    Joined:
    Oct 16, 2010
    #2
    It sounds like the hard disk may have a serious mechanical problem or bad block(s). If there is anything of great monetary value on it to you that is not already backed up, I would recommend sending it in to a professional (and reputable) data recovery service. Further use of the disk under this condition could reduce the probability of recovery substantially (this is especially true if the cause is a mechanical problem). You'll also need to consider the fact that professional data recovery services by a reputable firm will set you back a few K, so you should only send it in for data recovery if the value of the data on the disk is worth at least that much to you.
     
  3. Mad Pierre thread starter macrumors newbie

    Mad Pierre

    Joined:
    Jan 6, 2009
    #3
    mmmm

    I guess. The disk is two weeks old and a new install. A replacement for one that failed. This says to me that there may be something causing the disks to fail. All of the data is backed up and I have a spare disk of the same type, it's just the grief of the reinstall.

    It seems to me more likely that SuperDuper has not reset something - OSX thinks the disk is full, but it isn't - it reads perfectly on another machine via a USB caddy.
     
  4. Mactrillionaire macrumors regular

    Joined:
    Oct 16, 2010
    #4
    Hard disks don't always fail all at once. It can start to happen before you realize it is happening. The issue could be that there is a problem with a backup disk and Super Duper! might not realize there is a problem with it or that a specific operation such as preparing the disk to boot may not have gone as the program thought it did (because it may not have verified it). Disk Utility, on the other hand, isn't always going to repair everything that is wrong with a disk because there is no reasonable way to solve certain problems. At this point, the best bet is to start with a clean operating system installation on a newly formatted disk and move your backed up files over from that. I know it is a hassle to do this, but otherwise you really can't be sure what it is that you are getting that you didn't expect in your backups. If the backups won't boot, or have other corruption that should not be overlooked, it is best to start with a clean disk and clean OS install and copy your files over and reinstall the applications. That way, you will have a better idea of what you will be getting with your future backups.
     
  5. MacForScience macrumors 6502

    MacForScience

    Joined:
    Sep 7, 2010
    Location:
    USA
    #5
    When you ran disk util on it what errors popped up?

    Cheers
     
  6. kidhyun macrumors newbie

    Joined:
    Jan 25, 2011
    #6
    Hi, did you solve this issue?
    I got almost the same problem.
    I replaced my internal HD 250GB with 500GB using superduper a month ago. It worked fine until now. I tried to upgrade to snow leopard from leopard and during the installation, it stopped at the blue screen. (after install complete and rebooting)
    I tried to boot from installation DVD and it says that it can install since the disk 500GB is full.
    I entered console mode by pressing command+s, and when I typed df command, strangely enough, it says disk full. But I couldn't figure out using du command. All I can get it just about 250GB.
    I booted using my previous 250GB HD, and connect my 500GB using usb enclosure, and checked the 'get info' for all folders but I got 250GB, but in the disk utiliy, it says it's 500GB full.
    I am wondering if there is something during the superduper cloning process which kind of sets an indicator of the targeting disk space to be the same as the original one.
    I've been using 500GB fine with 250GB available until I tried to upgrade which might have something to do at the OS level..
     

Share This Page