OS X resets time to Jan 1, 2001

Discussion in 'macOS' started by weg, May 11, 2010.

  1. weg macrumors 6502a

    weg

    Joined:
    Mar 29, 2004
    Location:
    nj
    #1
    Hi,

    I've just booted my MacBook (Snow Leopard 10.6.3) and got a warning that my clock is set to a date before 2008 (it's Jan 1, 2001, 0:00) and that this may affect some applications. Moreover, OS X forgot my preferred wireless network (which makes me think it's not just the time server acting up). I've found out that other people had a similar problem, but I couldn't out the reason for this weird behavior. Did anyone here experience something similar?

    thx
    EDIT: Btw, I'm connected to a time server, so by now OS X is using the correct time again.
     
  2. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #2
    I'd say that your battery in the computer ran down, you know the old style batteries for the cmos, but MBPs don't have them.
     
  3. weg thread starter macrumors 6502a

    weg

    Joined:
    Mar 29, 2004
    Location:
    nj
    #3
    Yeah, Macs use EFI, they seem to have a PRAM battery, though.
     
  4. munkery macrumors 68020

    munkery

    Joined:
    Dec 18, 2006
    #4
    I had this occur after I played around with the firewall settings and then restarted my computer.

    Solved by turning off the firewall, deleting the firewall's .plist file, and restating the computer. I had to turn on the firewall and reconfigure it's setting after the restart, obviously.
     

Share This Page