OS X restore disk won't boot on Macbook Pro running Linux

Discussion in 'MacBook Pro' started by diallomarcel, Jan 21, 2011.

  1. diallomarcel macrumors newbie

    Joined:
    Jan 21, 2011
    #1
    I made the mistake of trying to install 10.6 from a friend's restore disk. After trying for a long time I thought that wiping my drive would help, it didn't and I didn't have my own restore disk to load Mac OS back onto my computer. I then installed Linux Mint and ordered a replacement restore disk from Apple. I finally received the disk yesterday, but the computer won't boot from the disk when I hold "C" while the computer is turning on. I tried doing the same with my Linux install disk and it worked perfectly. I would just get a white screen that would go on forever with the OS X restore disk.

    I need OS X back for school work and my warranty expired. I have a late 2009 MacBook Pro 15".

    Thanks in advance.

    Marcel
     
  2. Jare macrumors 65816

    Jare

    Joined:
    Jun 17, 2010
    Location:
    Canada
    #2
    Hold the "option" key when booting and select the CD from there. Sometimes C doesn't work, so use "option".
     
  3. diallomarcel thread starter macrumors newbie

    Joined:
    Jan 21, 2011
    #3
    I tried doing that, it displayed "OS X Install". However when I clicked on it it did the same as when I was holding C, a continuous blank white screen. I tried the same thing with my Mint disk and it worked. I also called Apple and they decided to send me another disk.
     
  4. antmo macrumors member

    Joined:
    Feb 20, 2008
    #4
    try resetting the pram... it may have been messed-up when the linux bootloader installed itself... it's worth a try.

    shutdown the machine, hold down 'p', 'r', 'option' and 'command' keys and start the machine, keep holding those keys down. after it resets, it should restart itself and it will be reset to the default brightness and chime volume.

    then try to booting the restore disc.
     
  5. diallomarcel thread starter macrumors newbie

    Joined:
    Jan 21, 2011
    #5
    I just tried it, didn't work. I guess I should just wait until I receive the other disk from Apple.
     

Share This Page