OS X Settings? Pioneer superdrive in G4 MDD doesn't mount

Discussion in 'macOS' started by ActionClaw, May 15, 2008.

  1. ActionClaw macrumors newbie

    Joined:
    Mar 25, 2008
    #1
    I'm posting in this forum because, though I'm a long time Mac user, I'm relatively new to OS X. It's entirely possible that my problem is merely due to a software/preferences/settings issue I may be overlooking or unfamiliar with.

    I recently purchased a G4 (MDD FW800, 1.42 GHz DP, Running OS 10.4.11) off Ebay that may or may not have a bad CD/DVD drive (PIONEER DVD-RW DVR-105, Revision: A506). The seller, of course, claims the drive was fine.


    What I've tried thus far:

    • F12 does open and close the tray
    • I've tried CDs and DVDs, music and data CDs, blank CDs, disks I've burned as well as commercially produced CDs and DVDs.
    • None automatically mount on the desktop. None appear in any finder window
    • I've tried several (commercially produced) DVDs but DVD player only reports "Supported Disk Not available"
    • Finder preferences --> general --> "Show these items on the Desktop: CDs,DVDs and Ipods" IS ticked
    • System profiler sees the drive on ATA bus
    • Disk Utility does not see it (loaded or not)
    • I have used Disk Utility to repair permissions on startup drive
      (obviously not from the CD as suggested)
    • I have reset p-ram
    • I tried it connected to the ATA-66: again, no change. Still seen in System profiler, still doesn't mount and surprisingly, F12 still opens/closes tray!
    • I've read about jumper issues, specifically, with Pioneer superdrives. It was jumpered as CABLE SELECT, I moved it to MASTER: no change


    My questions:

    • Is there any other preference setting, etc. I've overlooked?
    • I've read there were definite problems with Pioneer superdrives and 10.2.4. (http://www.xlr8yourmac.com/archives/feb03/021403.html) but I haven't yet found a similar situation with 10.4. Anyone else?
    • The seller claims, "The Pioneer A05, installed in the computer, was fully functional when it was here in our integration room. When I wiped the hard drive clean, with the OS disc that we have in house, the disc appeared on the desk top- with no problems.". Is it possible there is some "driver" or the equivalent that may have been in the previous OS but not the recently loaded (10.2.4.)?
    • In previous Mac systems, if a prefs file somehow got corrupted, you dragged it to the trash, emptied the trash, restarted and (usually) all was well. Is there an OS X equivalent?
    • Is there any diagnostics/utility either bundled with OS X or available as freeware/shareware I could use to test the drive?
    • Might it respond to a firmware upgrade?
      (yes, I realize this can only be done from a PC)
    • More and more, I'm beginning to think I have a dead drive but (though I shouldn't have to do so) if I'm forced to purchase a new one, how can I confirm with certainty that this drive is, in fact, beyond repair and definitely dead?
    • I have a few working G3 iMac CD/DVD drives. Would they work in this as a temporary read only replacement?
    • What else might I try? Any and all comments, suggestions, etc are welcome!

    Thanks in advance for any help. Answers to any of these questions is appreciated. Thanks!
     
  2. jeremy.king macrumors 603

    jeremy.king

    Joined:
    Jul 23, 2002
    Location:
    Fuquay Varina, NC
  3. ActionClaw thread starter macrumors newbie

    Joined:
    Mar 25, 2008
    #3
    I don't know; do I?:)

    I suppose it couldn't hurt to try. I'm not really very familiar with Patchburn but..

    1. Doesn't a burner that requires Patchburn otherwise still mount and operate normally as a reader?
    2. Isn't this only necessary for "non-standard" drives? I believe the PIONEER superdrives were OEM
     
  4. jeremy.king macrumors 603

    jeremy.king

    Joined:
    Jul 23, 2002
    Location:
    Fuquay Varina, NC
    #4
    I'd try it and report back.
     

Share This Page