OS X (Snow Leopard) not loading/booting into properly, has constant spinning gear.

Discussion in 'iMac' started by speedfreek, Jun 13, 2011.

  1. speedfreek macrumors newbie

    Joined:
    May 25, 2008
    #1
    So, my mum's iMac isn't loading properly into OS X (Snow Leopard), there's the grey apple Icon, the spinning gear thing and a loading bar that only progresses a small part before disappearing and it's just the Apple icon and the spinning gear.

    I have tried holding shift to get into Safe Mode but it just gets the same result.

    Apparently before this started, she booted into OS X fine (as I was using Bootcamped Windows) and was able to login but after going to applications, the mouse icon turned to the spinning pinwheel and wouldn't move according to her, that's when she restarted it.

    I can boot into bootcamped win 7 as i hold alt/option button down to select which one i go into and it works fine but it seems that the os x partition is a bit munted?
     
  2. rkaufmann87 macrumors 68000

    rkaufmann87

    Joined:
    Dec 17, 2009
    Location:
    Folsom, CA
    #2
    I suspect a failing or failed HD. Run Apple Hardware Test in Extended Mode to test it.

    Roger
     
  3. speedfreek, Jun 13, 2011
    Last edited: Jun 15, 2011

    speedfreek thread starter macrumors newbie

    Joined:
    May 25, 2008
    #3
    Ran the test, came up with nothing, then rebooted into OS X fine. Logged in and after the startup programs loaded, it had the coloured pinwheel. During that time, none of the desktop icons loaded and I really couldn't do much apart from startup loading programs.

    Tried loading finder from the dock but nothing happened, so ended up running the test again and nothing found again, reboot and same issue of not booting into OS X.


    Edit: Nothing resulted from doing the hardware tests, after running Disk Utility from the startup disk, it has found an invalid sibling link of which Disk Utility is unable to repair.

    I also did fsck_hfs thing in terminal after finding it on macworld.com for a supposed fix and it couldn't complete that, though i did the repair disk thing after doing fsck_hfs and it couldn't do it.


    So is the alternative to just do a reformat?

    Edit: Installed OS X onto a thumbdrive and got DiskWarrior working that way and managed to fix the hard drive.
     

Share This Page