OS X UI Choppy on 395X

mattoligy

macrumors 6502
Original poster
May 15, 2010
396
191
Cloud 9
Been using my new i7 395X 512Flash for a few days now and have noticed some of the animations in El Cap lagging! Is this normal for the highest priced gfx chip? Or is it the OS? Because if it's the former I may consider returning the iMac as this price for a choppy running machine is frankly ridiculous :-/

Edit: Nothing taxing running in the bg, just Safari and iTunes on a fresh install!
 

AlifTheUnseen

macrumors member
May 17, 2014
90
48
Don't know it from own experience but I think I remember there was a somewhat similar experience with the then-new 2014 Retina iMac… Don't know whether it was OS-X-related and whether it got fixed eventually… RiMac users might help here...
 

Samuelsan2001

macrumors 604
Oct 24, 2013
7,682
2,103
Been using my new i7 395X 512Flash for a few days now and have noticed some of the animations in El Cap lagging! Is this normal for the highest priced gfx chip? Or is it the OS? Because if it's the former I may consider returning the iMac as this price for a choppy running machine is frankly ridiculous :-/

Edit: Nothing taxing running in the bg, just Safari and iTunes on a fresh install!
Assuming the computer isn't spotlight indexing (this causes a lot of issues if you have just migrated a lot of data to the machine and can take hours to complete) just take it back to apple, as you say thats not what you want from a new iMac.
 

alexxk

macrumors 6502
Jul 29, 2010
340
45
Makes me wonder if buying from Bhphoto is a good option. If I have issues such as this and need a return I don't know if I will encounter a hassle from them.
 

alexxk

macrumors 6502
Jul 29, 2010
340
45
Ask about the returns policy before you buy.
They accpet defected machines back.. but if im not simply satisfied and just want a return they will not accept.

An issue such as this from the OP, Im not sure how they would handle..
 

mattoligy

macrumors 6502
Original poster
May 15, 2010
396
191
Cloud 9
It happens when swiping between full screen apps but mainly within the new photos app when opening a thumbnail to a full screen image and back to a thumbnail again! No spotlight indexing going on but I'm just wondering if it's the photos application as I have had that open a lot, including when I have experienced slow downs in the UI...
 

Buerkletucson

macrumors 6502
Sep 12, 2015
476
246
Are you sure it isn't "buttery smooth" vs "lightning fast"? As cliche as "Safari is snappier".. :eek:
My experience......my words.

Wasn't responding for your benefit and don't particularly care what you think...... :)
 

iemcj

macrumors 6502
Oct 31, 2015
299
79
Check activity monitor. Anything running? Like someone else said, if it's indexing, could be why. I have that same chip and it's as buttery and snappy as it gets. Make sure you're on the latest update for osx, could be a random glitch that's happening for ya, no way does it have anything to do with the graphics card haha
 
  • Like
Reactions: Buerkletucson

alexxk

macrumors 6502
Jul 29, 2010
340
45
Screw it. Cancelled my order with Bhphoto and ordered with Apple just u case I need support.

Same computer I7 4.0ghz 512 ssd M395x