OS X upgrade keeps hanging on my MacBook

Discussion in 'macOS' started by davenet, Aug 20, 2008.

  1. davenet macrumors newbie

    Joined:
    Oct 6, 2004
    #1
    Hi all,

    I just acquired a recent model MacBook second hand. It's a black one with 2.4GHz CPU and 2GB of RAM. I am now wiping the hard drive and reinstalling the OS. I don't have the original CD just yet, but I have a OS X Leopard 10.5 disc (it came pre-installed with probably 10.5.3).

    I am able to load 10.5 just fine. However when I try to install the 10.5.4 update directly, the process "hangs" before it is complete. I think it stops at 62% or so. I let it sit for quite a while.

    So my next trial was to do the updates one by one. I can get through the 10.5.1 update just fine. But when I get to the 10.5.2 update, then it hangs at around 83%.

    I've tried this now like 4 times. I'm looking for suggestions, etc. Please someone help me understand how I might be able to get the updates installed.

    Thanks,

    David
     
  2. davenet thread starter macrumors newbie

    Joined:
    Oct 6, 2004
    #2
    Apparently this is stumping everyone? Was hoping someone might have a suggestion. May have to end up calling Apple support.

    David
     
  3. TwinCities Dan macrumors 603

    TwinCities Dan

    Joined:
    May 19, 2008
    Location:
    Double Parked out front of the Courthouse
    #3
    hmmm...It seems like you are doing your part right. How are you applying the updates? From "Software Update"? :confused:
     
  4. davenet thread starter macrumors newbie

    Joined:
    Oct 6, 2004
    #4
    That is the first thing I tried, going from 10.5 straight to 10.5.4, but when that hung, I decided to try downloading them individually. At this point the problem seems to be on 10.5.2 (something in that update hangs).

    David
     
  5. davenet thread starter macrumors newbie

    Joined:
    Oct 6, 2004
    #5
    Just an update, I ran a drive repair and I tested the memory. No problems found from those tests.

    I guess my next step would be to try installing 10.5.3 or .4 directly instead of starting with the 10.5 build, what do you all think? This computer was purchased in April, so maybe it doesn't like the earlier builds?
     
  6. Apple Ink macrumors 68000

    Apple Ink

    Joined:
    Mar 7, 2008
    #6
    Have you tried Disk repair from disk utility? Repair permissions and then, to repair disk... boot from the install disk!
     
  7. davenet thread starter macrumors newbie

    Joined:
    Oct 6, 2004
    #7
    I thought I did a repair disk. I did boot from the install disk for this operation. I am not sure if I repaired permissions. I did a clean install, wouldn't that by default install the correct permissions?
     

Share This Page