OS X Web Sharing Problem

stoavio

macrumors member
Original poster
Jun 8, 2006
46
0
When I first investigated the Web Sharing option I know for a fact it worked. Awhile ago I was trying to install Apache (which at the time I had no clue it was already installed and basically OS X already comes with an operational web server configuration). I believe I may have overwritten some files because now the Web Sharing option in my System Preferences is grayed out and this message is displayed:

Web Sharing is not installed on this computer. To install Web Sharing, use the Mac OS X installer.
I installed one of the packages here: http://www.entropy.ch/software/macosx/. After that Personal Web Sharing will no longer turn on.

I've tried inserting the system disc but it just wants me to restart so I can install OS X and I'm afraid to try because I don't want to reinstall it. I just want to restore Web Sharing functionality.

Any ideas? Could another mac user maybe look in the directory the apache/web server files are stored and compare them against the files I have? I think something was either overwritten or removed.

TIA for your help,

Mason
 

MisterMe

macrumors G4
Jul 17, 2002
10,650
28
USA
IIRC, user-installed Apache defaults to a different path than Personal Web Sharing. After installing Apache, you must change the path to that expected by PWS.
 

stoavio

macrumors member
Original poster
Jun 8, 2006
46
0
MisterMe said:
IIRC, user-installed Apache defaults to a different path than Personal Web Sharing. After installing Apache, you must change the path to that expected by PWS.
Oh, cool. How do I do that?
 

ebrentnelson

macrumors newbie
Mar 21, 2008
1
0
Any solution to this?

I know it has been a million years since this was addressed, but I made the same mistake with trying to get PHP5 working on my machine. That didn't work and now its weird. Only the computer's web site works (http://localhost) but my personal website (http://localhost/~user) isn't recognized at all. And PHP4 doesn't work at all (I have uncommented the lines in the httpd.conf).

Help.

Thanks.