OS X won't boot, Windows 7 does.

Discussion in 'MacBook Pro' started by Highest, Nov 29, 2014.

  1. Highest macrumors newbie

    Joined:
    Nov 29, 2014
    #1
    TL;DR so basically, my problem is that my Macintosh HD partition (OS X) is somehow blocked and I can't format it, I can't boot into it, I can't write files into it and I can't even mount it back. Good thing is atleast I could make a copy of my files to an external drive from a Windows 7 partition I had installed before this problem happened and I can actually boot into this Windows 7 Partition but not the OS X one.

    I'll make this as detailed and informative as possible, I'm pretty desperate now and I just want to solve this.

    A few weeks ago I got Windows 7 as a partition on my Mid-2012 Macbook Pro 13" (the last non-retina model), I got the base model, which as a core i5 cpu, 4GB of ram (upgraded to 8GB recently), Intel Graphics 4000 etcetera, model no. is A1278 I believe.

    Okay, so the reason I installed Windows 7 in a bootcamp fashion is because I have to run Revit/Lumion and other various software that aren't available on OS X, for I study architecture and I require them, I tried using Parallels but I just did find the bootcamp experience a little more pleasant and natural. Naturally, whenever I wanted to use those programs, I had to restart my notebook and boot into windows, and I didn't find this extenuating or unpleasant, but then, a few days ago, after doing what I wanted to do on the windows partition, I tried to go back to OS X, selecting the option "Restart in OS X" from the Bootcamp Assistant in windows. After that, my sytem restarted and just went normaly into the apple loading screen before OS X boots completely, but, this time, a loading bar appeared under the apple and just started loading for... well, a little more than 10 minutes, then, when it finished, I got a message saying that OS X couldn't be accessed or couldn't load, something like that, and I still get it, so I've been using windows since then, because funny enough, my windows partition DOES work, but my OS X partition doesn't.

    So I've read a few threads on different forums and trying everything, but the thing that gave me more info about my problem was when I booted into recovery mode and saw that my Macintosh HD partition was "unmounted", naturally I thought "so THAT was it!!!" and tried to mount it, but it didn't, it told me to verify the drive and try again, so I did, and the Disk Utility in recovery mode found that my drive (only Macintosh HD partition) needed to be repaired, so again I tried to do it and clicked on Repair right there in the Disk Utility, but then again I couldn't repair it and it told me to make a copy of all my files and make a clean install of mavericks again (this happened a few weeks ago when yosemite wasn't out), so I told myself "meh, I can still copy-paste the files from my windows partition into an external drive and just format the Macintosh HD partition and re-install Mavericks. I did that, and then went back to disk utility on recovery mode, and when I tried to re-install mavericks on that drive, when I tried to choose the Macintosh HD partition it told me that "This drive is blocked".

    I don't know how in the world could I block my own OS X partition but I hope someone can help me, please, this is driving me crazy. Thanks in advance guys.

    Also, sorry, I didn't know where else to put this thread in, I'm very desperate!

    MacBook Pro, OS X Mavericks (10.9.5), Model No. A1278
     
  2. JoelTheSuperior macrumors 6502

    JoelTheSuperior

    Joined:
    Feb 10, 2014
    Location:
    London, UK
    #2
    It honestly sounds to me like the harddrive is failing, and OS X just happened to be affected before Windows was.

    What you can try though is to fire up disk utility from a recovery disc or some such (not the recovery partition) and:
    1. Select the drive
    2. Go to partitions
    3. Select the 1 partition option
    4. Click options and choose GUID Partition Map
    5. Click apply and create the new partition map

    And then see if you're able to install OS X on the machine after doing this.

    In all honesty though I suspect the harddrive has most likely failed.
     
  3. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #3
    After you installed windows, did you ever boot back into OS X, or were you in windows 100% of the time until now?

    The reason I ask, I wonder if you installed windows over OS X.

    The best bet is to boot into the recovery partition and first run the Disk Utility to see if there's any issues with the drive and second to validate that you have an OS X partition, and if not re-install it.
     
  4. Highest thread starter macrumors newbie

    Joined:
    Nov 29, 2014
    #4
    I already tried this. Didn't work at all, I believe I'll need to buy a new drive... oh well, time to try SSD's :) but still I can't believe this is happening haha.

    ----------

    I didn't install Windows over OS X, for the first 2 weeks I was regularly using both OS's without any problem :eek:
     

Share This Page