OS X won't finish startup

Discussion in 'Mac Basics and Help' started by rage4lifebj, Nov 26, 2007.

  1. rage4lifebj macrumors newbie

    Joined:
    Nov 26, 2007
    #1
    I few days ago I tried to install the system update to 10.411, and it couldn't do it for some reason. So I ran disk utility and repaired the permissions, and then tried to verify the disk. It failed to verify the disk and said that "keys were out of order." Now my G5 won't finish starting up: the blue bar fills up, but never goes away.

    Command+S doesn't do anything.
    Option doesn't do anything.
    Command+option+P+R works, I think, but doesn't make it start up.
    Shift causes it to shut down after the spinning widget screen.
    C doesn't do anything (my boot cd is in)

    I don't know what to do, please help!
     
  2. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #2
    There are other possibilities, but it sounds an awful lot like your hard drive is corrupt. Hopefully it's just a corrupt directory structure, not failing hardware, but the first thing to do (if you haven't already) is back up. NOW.

    After backing up, you're probably going to have to do a reinstall, but you're going to want to clean up the drive first. If you have a copy of TechTool or Diskwarrior or the like, use that. If not, boot from the OS install disc, launch Disk Utility from the menu, and do a Repair on the disk (not permissions repair, the button on the right). If it shows errors keep doing it until it gives a clean bill of health.

    When that's looking good, do an Archive and Install (preserving users), THEN update to 10.4.11, and hopefully all will be well.

    If Disk Utility can't repair it (and again, assuming that the SMART status isn't showing failing or the like), or if you want to be more careful, you're going to need to completely wipe the drive and install a fresh copy. BACK UP first, because anything on that drive that isn't backed up will go poof permanently.

    Once backed up (twice, if you're paranoid), do an Erase and Install, then use the setup assistant that shows up when you first boot to import your users from the backup you made. Then update to 10.4.11 and hopefully all is well.
     

Share This Page