OS X Yosemite installation stuck on a blackscreen

Discussion in 'OS X Yosemite (10.10)' started by Maverick Maxx, Oct 16, 2014.

  1. Maverick Maxx macrumors newbie

    Joined:
    Oct 16, 2014
    #1
    My installation of OS X yosemite is stuck on a blackscreen with apple logo and white status bar under it. Its more than an hour now that it is stuck here. I have no clue what should I do now. Can someone suggest a way to get out of this? Thanks
     
  2. Alejandra36 macrumors newbie

    Joined:
    Oct 17, 2014
    #2
    Yosemite installation stuck

    I have the same problema. Can I reboot using the power button. Is it safe?
     
  3. Uncle David macrumors member

    Joined:
    Jun 21, 2011
    #3
    I'm stuck at the same point, but mine is a white screen with a black progress bar. Luckily I have a clone so I can reinstall the partition if things don't get resolved, but I'd like some advice on how to proceed.
     
  4. romeyn macrumors newbie

    Joined:
    Nov 1, 2009
    #4
    Same problem. Black screen post-install with white Apple Logo and "loading" bar underneath. Gets about 1/3 along and then I get the rainbow beach ball.

    Have tried re-installing twice and let it run in that state for HOURS. Booting in single-user or verbose mode is of no help
     
  5. Sandy131 macrumors newbie

    Joined:
    Oct 17, 2014
    #5
    Stuck on black screen too...

    I unplugged my iMac because I couldn't do anything - power off with power button - plugged back in and still have black screen w/Apple logo and progress bar stuck at about 1/4 of the way - it's been like that for over 6 hours. Eeeek.... What can I do?
     
  6. mattrdesign macrumors newbie

    Joined:
    Oct 17, 2014
    #6
    Ok I had this very same issue, but I got passed it and I have no Idea why. Here’s what I did:

    My 2011 MacBook Pro was stuck on the boot screen (Apple logo and progress bar) after a seemingly successful installation. The progress bar was stuck at around half way for 2 hours.

    So I force power down and restart. Same thing happens again.

    So I boot into my Windows 7 partition to find a solution. No answers are found other than to boot into the recovery disk and reinstall

    I shut down Windows and boot into the recovery disk. I was about to hit reinstall when I realized that I need to back up a few files I’ve been neglecting for a while. So I shut down the recovery disk without doing anything.

    I then restart the computer but I forgot to hold down Option and it starts to boot into the the disk I tried to install Yosemite on, and IT WORKED! It booted into Yosemite normally and I’ve not run into any further issues.

    So it seems the solution to this problem is:
    1) Force power down
    2) Boot into Windows and putz around the Web for a while before shutting down.
    3) Boot into the Recovery Drive and don’t do anything, then shut down again.
    4) Boot up normally and it works
    5) …
    6) Profit!

    This worked for me for what seems to be the very same issue as the OP, but I stumbled on to the solution by accident so YMMV.
     
  7. halanr macrumors newbie

    Joined:
    Oct 19, 2014
    #7
    Problem Solved

    I had the identical problem. I downloaded Yosemite from app store, began installation, and after required restart apple logo would appear and it would begin to load and I saw the installation bar begin to move and show percentage of installation--then when it got a quarter of the way installed the screen switched to a blank white screen and sat like this for a day! I tried everything, unplugged, forced reboot, power on and off, etc.--all with same results. Then I did hard power off and on and entered safe boot mode. Here's how to do that:

    Be sure your Mac is shut down.
    Press the power button.
    Immediately after you hear the startup sound, press and hold the Shift key. The Shift key should be pressed as soon as possible after startup, but not before the startup sound.
    Release the Shift key when you see the Apple logo appear on the screen.

    Eventually the computer did enter safe boot mode and once it did it finished installing Yosemite. I then, based upon what I'd read on this page, repaired all disk permissions and then when that was finished and the installation was finished restarted the computer and that worked and all was good in the hood! Hope this saves everyone the aggravation and madness I went through on my end for the last 3 days. Thanks and good luck!
     
  8. brians702 macrumors newbie

    Joined:
    Oct 19, 2014
    #8
    OS X Yosemite installation stuck on a blackscreen, Apple Logo

    I also tried booting into safe mode which allowed the installation to complete. However upon reboot, I found myself still waiting on the black screen with Apple logo and the white progress bar stuck at a third progress.

    Here's what I did to resolve:

    1. Cleaned out and formatted an older USB External Drive
    2. Boot back into safe boot
    3. Ran Time Machine while in safe mode (it actually works), using the just formatted external drive
    4. Booted into Internet Recovery mode (option + ctrl + R)
    5. Formatted startup disk
    6. Installed Mavericks
    7. Upgraded to Yosemite from apps store
    8. Ran Migration Assistant and used Time Machine backup as the source
    9. Voila all my documents and applications transferred over. Most of my settings transferred over, which is not a huge deal as settings can be reconfigured. The important thing is the critical data was not completely lost and having to reinstall all my applications would be a lengthy cumbersome tasks.

    Hope this helps, anyone else out there
     

Share This Page