OS X Yosemite on unsupported MacBook

Discussion in 'OS X Yosemite (10.10)' started by amitkottur, Jul 31, 2014.

  1. amitkottur macrumors newbie

    Joined:
    Jul 27, 2014
    #1
    I was able to install Yosemite on my MacBook4,1 by creating USB bootable version of Yosemite. Changes required were the usual OSXInstall.mpkg replacement and update to .plist files.

    However, after installation I am unable to boot into Yosemite :confused:. Any thoughts on how to get it working?
     
  2. jonobin macrumors regular

    Joined:
    Sep 3, 2014
    #2
    http://swegen.blogspot.it/2011/07/bootefi-x64-patch-for-mac-os-x-lion-and.html?m=1
    Try these kext and let me know of they works.. I have a 3,1 macbook with the same gpu and I'm also inetersted to have yosemite or at least a fully working mavericks in my macbook ;)
     
  3. jonobin macrumors regular

    Joined:
    Sep 3, 2014
    #3
    maybe you have to modify the plist adding your motherboard to compatibles ones
     
  4. TMRJIJ, Sep 10, 2014
    Last edited: Sep 10, 2014

    TMRJIJ macrumors 68020

    TMRJIJ

    Joined:
    Dec 12, 2011
    Location:
    South Carolina, United States
    #5
    During the Installation. It adds a new platformsupport.plist that does not have your Mac identified as supportive.

    Try opening up the OS X Install Usb and find the Terminal. Enter this:
    sudo rm /Volumes/<10.10 Partition>/System/Library/CoreServices/PlatformSupport.plist

    Make sure you have 64bit kexts from OS X (10.6.2) Snow Leopard to help avoid the harsh graphical artifacts.
    Unsigned or improperly signed kexts will not be loaded easily. To use unsigned kexts during development, this strict check can be disabled by adding a “kext-dev-mode=1” boot arg.
    Installing kernel extensions on systems running the Public Beta and Developer's Preview may make your system un-bootable. To fix the issue, boot into the Recovery Partition and run the following:
    touch /Volumes/<10.10 Partition>/System/Library/Extensions
    kextcache -u /Volumes/<10.10 Partition>

    We are working on making automated Yosemite Patches and Recovery Partition Creation on these unsupportive macs as well.

    http://forums.macrumors.com/showthread.php?p=19609244#post19609244
     
  5. TMRJIJ macrumors 68020

    TMRJIJ

    Joined:
    Dec 12, 2011
    Location:
    South Carolina, United States
    #6
    Here is my Guide for Mavericks. Yosemite may have a signed OSInstall.mpkg but you should be able to get past that easily:
    https://db.tt/eELXN8QT

    You may use those kexts in your provided link or pm me for working ones.
     
  6. jonobin macrumors regular

    Joined:
    Sep 3, 2014
    #7
    what do you mean for "working ones"?
     
  7. Manic Harmonic macrumors 6502

    Joined:
    Dec 4, 2011
    #8
    The old Intel and nvidia graphics that came on these macs don't have kexts in anything past lion, and after that there's no support for 32-bit kexts. The only 64 bit kexts for them are the one from 10.6.2.
     
  8. Kishtel macrumors newbie

    Kishtel

    Joined:
    Jan 11, 2015
    #9
    I had the same problem.
    So using SFOTT I successfully installed Os X 10.10 Yosemite Beta on my MacBook 4,1 with the help of this, but was unable to boot into Yosemite partition.

    My problem was solved:
    After installation sfott on your USB-stick try to replace boot.efi BOTH in /System/Library/CoreServices/boot.efi AND /usr/standalone/i386/boot.efi
    It works on my own.
     
  9. rhyd159 macrumors newbie

    Joined:
    Jun 21, 2015
    #10
    How do I update my mac to 10.10.3, I have a macbook 3,1 and managed to install yosemite using sfott and changing the plist, I want to update to 10.10.3 I tried with software update and I had a prohibitory sign. Was wondering how I go about updating and having working intel x3100 kexts.
    Thanks
     
  10. TMRJIJ macrumors 68020

    TMRJIJ

    Joined:
    Dec 12, 2011
    Location:
    South Carolina, United States
    #11
    This thread is kinda dead. Here is our main thread:
    http://forums.macrumors.com/showthread.php?t=1761432

    I explained how I did it in post 749.
     
  11. cristsp macrumors newbie

    cristsp

    Joined:
    Oct 15, 2016
    Location:
    BRAZIL
    #12
    hello friends I am new here, I would like to welcome you all, I have a problem a few days because of a problem in advertising page can not proceed with the installation of Yosemite by MacpostFactor 2.0.1, someone can help me, or have any news about this topic, I am in touch with the developers of the program but not yet have a solution for it 41ee643d6434f87b005f6d8b2ce300efaf86a151d0e4e11b5ba37bbcfc91191b.jpg
     
  12. RobstaHendricks macrumors newbie

    Joined:
    Feb 23, 2011
    #13
    I had to use a friend's machine (French laptop) with AdBlocker Plus in Firefox (seperately)... Disable it, then there's a menu under that with an arrow to the with two options... one is Java and Firfox, then another. untick both and reopen MacPF.

    Im English and was using a French language laptop, so sorry if vague, but that got me past those steps...

    I believe it's since been fixed...
     
  13. spooks115 macrumors newbie

    spooks115

    Joined:
    Dec 11, 2016
    Location:
    UK
    #14
    do you have the sound working? as I have yosemite installed on my MacBook 4,1 but have no sound I have the kext installer and a appleHDA installer but no idea which codec is in this MacBook
     

Share This Page