OSX 10.4.7 unable to update ANY software.

Discussion in 'macOS' started by DannyO, Jul 4, 2007.

  1. DannyO macrumors newbie

    Joined:
    Jul 4, 2007
    #1
    Hi everyone, first time poster, long time lurker, I got a bit of a strange problem that I cannot seem to fix and am hoping someone here has the answer.

    I'm currently running OSX 10.4.7 and everything is running fine, except that software update does not detect that anything needs to be updated, it says everything is upto date (but now and then it will tell me if iTunes needs an update), when theres plenty that needs an update, and if I download any update seperately, it still won't install, plus some software I have tried to update, like Remote Desktop, says that is does not support the language that my system is running, I've only got English down as my language.

    Its been like this for awhile but now I NEED to update some things, I've tried looking for info about this and have came up short, also tried repairing permissions with no effect, and its starting to look more and more like I will need to format, which I really don't want to do as its a crap way of fixing a problem.

    Any help is much appreciated.
     
  2. Multimedia macrumors 603

    Multimedia

    Joined:
    Jul 27, 2001
    Location:
    Santa Cruz CA, Silicon Beach
    #2
    I Know This Indication And Solution

    Happened to me too. You have to Archive and Install from your Tiger Install DVD. Then run the 10.4.10 Combo Installer to get it up to date. The rest of the install options should be offered and be installable once you do that. You will keep your settings. :)
     
  3. cbrain macrumors 65816

    cbrain

    Joined:
    Dec 9, 2006
    Location:
    North-East, UK
    #3
    This happened to me a little while ago, I was running 10.4.8, I updated 10.4.9 and everything was fine.
     

Share This Page