OSX 10.9 Dock causes rMBP to use discrete graphics

doopsie

macrumors member
Original poster
May 19, 2007
54
0
Hello guys!

After installing the GM, I realised that the com.apple.dock.extra always appears as an App using significant energy, and always causes the discrete graphics card t take over.

Anyone else facing a similar issue?
 

vanc

macrumors 6502
Nov 21, 2007
327
5
Do you have any plugins? My rMBP works fine on Mavericks with iGPU most of the time. Only if I open iPhoto, or VLC. But I can still be able to use gfxCardStatus to force iGPU.
 
Comment

nontroppo

macrumors 6502
Mar 11, 2009
430
21
Nope Dock and apple.com.dock.extra cause 0.0 energy impact and don't trigger discrete GPU here.

Perhaps you need to reset your dock?
 
Comment

danwilson

macrumors newbie
Oct 17, 2013
2
0
I'm having the same issue on my original 15 inch rMBP.

Have you found any solutions since you originally posted?
 
Comment

grabaslab

macrumors newbie
Jun 14, 2002
6
0
all over
Same problem here

I have the same issue on a Macbook pro 2010 model. I've replaced the HD with an sad and increased ram.

Have installed gfxcardstatus, and it shows the dependency and the dock process triggering the gpu. I've tried

rm ~/Library/Preferences/com.apple.dock.plist{,.lockfile}; killall Dock

and while the dock is inactive (split second until it restarts), the gpu falls back to integrated. When the dock comes back up, gnu goes to discrete again.

I then set up a second, completely blank, user account to test; the behavior is not evident there, so 1) it is not system wide but User based, and 2) is likely to be provoked by some installed utility (I have no idea which one at this point, will continue looking).

Any ideas?
 
Comment

Junkyman

macrumors regular
Sep 19, 2012
112
1
Hey guys,

I'm having the same issue. My rMBP is constantly using the dGPU and I have no idea why.

Anyone an idea? :confused:
 
Comment

grabaslab

macrumors newbie
Jun 14, 2002
6
0
all over
Hello all, problem solved, at least for me

credit goes to jximo 07 for the following post:
https://discussions.apple.com/message/21616026#21616026

Go to
/System/Library/CoreServices/Dock.app
show package contents

/Contents/XPCServices/com.apple.dock.extra.xpc
show package contents

/Contents/MacOS/
delete com.apple.dock.extra.xpc

use activity monitor to force quit the equivalent process, empty trash, and voila. I've been running for several hours without adverse effects, and gfxcardstatus happily has me on integrated only.

I believe the deleted file and process have to with debugging and Xcode (I have installed developer tools), I backed up the deleted file to a compressed zip on the desktop just in case, but haven't needed it.

Can others try it and post their results?
 
Comment

dusk007

macrumors 68040
Dec 5, 2009
3,386
62
For me Spotify shows up in the dependency list now. It didn't in 10.8 after some updates.
I don't know who said that Mavericks is a little less ridiclous on graphics switching it clearly is even more so for me.
 
Comment

grabaslab

macrumors newbie
Jun 14, 2002
6
0
all over
Second day running, everything is fine. I've been using gfxcardstatus on Mavericks with no issues. It switches to discrete on wake from sleep, but I just switch it back to the integrated gpu.

Getting much better battery time compared to ML, system zippier as well. Overall quite happy now that I'm over the dock triggering the discrete gpu and killing the battery.
 
Comment

Sir Al

macrumors member
Feb 14, 2005
98
1
Vancouver, Canada
Hello all, problem solved, at least for me

<snip>

I believe the deleted file and process have to with debugging and Xcode (I have installed developer tools), I backed up the deleted file to a compressed zip on the desktop just in case, but haven't needed it.

Can others try it and post their results?
I tried it, and I didn't have the Contents/MacOS/com.apple.dock.extra.xpc file, I did have the XPCServices folder with it inside. I backed it up and trashed it. Force Quit restarted the process and it worked. Haven't noticed anything break, so this workaround is working for me for now.

However, it's quite bothersome that this problem exists. I hope Apple acknowledges it and fixes it. I have a mostly stock system, not too many programs and software. It's a Retina MacBook Pro 15" from the first generation they were released. Can't believe a bug like this could creep past their quality assurance. I haven't noticed too many hits on Google regarding this, though. I did find this thread via Google, however. Hehe.
 
Comment

zflauaus

macrumors 65816
Nov 19, 2004
1,166
3
I had this issue on my non-retina MBP. The issue with mine was that I had BusyCal installed. Removed that using AppCleaner and problem is fixed.
 
Comment

richardreeve

macrumors newbie
Oct 26, 2013
1
0
I have a different solution that doesn't require us to delete an unknown application that forms part of the dock. Whether it's a better solution, I leave for you to judge. I've taken the idea from the solution to stop XQuartz requiring the discrete graphics card here.

  1. Start Terminal in an administrator account
  2. In a terminal window go to the location of the Info.plist file for com.apple.dock.extra:
    Code:
    [COLOR="red"]$[/COLOR] cd /System/Library/CoreServices/Dock.app/Contents/XPCServices/com.apple.dock.extra.xpc/Contents
  3. Open the file with an editor, e.g. emacs. You have to use "sudo" and enter your password, otherwise you won't be allowed to edit the file:
    Code:
    [COLOR="red"]$[/COLOR] sudo emacs Info.plist
  4. Info.plist is a plain text file in xml format. After the LSMinimumSystemVersion key, modify the file such that it looks like this afterwards (i.e. add the red stuff!):
    Code:
    <key>LSMinimumSystemVersion</key>
    <string>10.7</string>
    [COLOR="Red"]<key>NSSupportsAutomaticGraphicsSwitching</key>
    <true/>[/COLOR]
  5. Save the file (Ctrl-X, Ctrl-S in emacs), exit the editor, log out, and log back in again. The integrated GPU should now be active.
Basically, what this does is to tell Mac OS X that com.apple.dock.extra can run on the integrated GPU by setting NSSupportsAutomaticGraphicsSwitching. The documentation for this key can be found here. Obviously, I've got no idea whether it can, and it may toast your machine and and I take no responsibility for it, but it seems to work fine for me, and I thought I'd let people know that the alternative exists to keep the dock fully functional...

Cheers,

R.
 
Comment

bitninja

macrumors regular
Jun 16, 2007
236
0
San Jose, CA, USA
I have a different solution that doesn't require us to delete an unknown application that forms part of the dock. Whether it's a better solution, I leave for you to judge.
I'd second richardreeve's solution — it's perfectly safe. Deleting the com.apple.dock.extra XPC service is absolutely not the right way to "fix" this.

Alternatively, for an even safer solution, clear away all of your Dashboard widgets (Dashboard runs in the context of the Dock, so it makes sense that a widget could cause this) and see if that fixes the issue (you might have to log out/in or restart your machine after the widgets are closed — I'm not 100% sure). Lots of people have reported success via this method as well.
 
Comment

dempson

macrumors regular
Jun 10, 2007
110
5
Wellington, New Zealand
I had this issue on my non-retina MBP. The issue with mine was that I had BusyCal installed. Removed that using AppCleaner and problem is fixed.
Thanks for the tip, zflauaus.

Same problem for me, affecting both my 2010 MacBook Pro (when booted from Mavericks) and my 2013 rMBP.

Same solution: deleted both the 1.6 (no longer useful due to SyncServices being gone) and 2.x versions of BusyCal, and all their support files and preferences, restarted, and now I'm running on integrated graphics.

BusyCal wasn't running and I didn't have its icon in the dock - it was just sitting idle in the Applications folder.

I'll do a more controlled test later to narrow down exactly which version and file was triggering this.

I had already tried removing every icon from Dock apart from Finder and Trash, and closing all items in Dashboard. Neither helped.
 
Comment

dempson

macrumors regular
Jun 10, 2007
110
5
Wellington, New Zealand
Same solution: deleted both the 1.6 (no longer useful due to SyncServices being gone) and 2.x versions of BusyCal, and all their support files and preferences, restarted, and now I'm running on integrated graphics.
Turns out that all I needed to do was delete BusyCal 1.6 (useless under Mavericks) from the Applications folder, then restart. The support files didn't make any difference, and it was OK to have BusyCal 2.5.2 (now 2.5.3) installed.
 
Comment

Sital

macrumors 68000
May 31, 2012
1,854
373
New England
I had this issue on my non-retina MBP. The issue with mine was that I had BusyCal installed. Removed that using AppCleaner and problem is fixed.
Turns out that all I needed to do was delete BusyCal 1.6 (useless under Mavericks) from the Applications folder, then restart. The support files didn't make any difference, and it was OK to have BusyCal 2.5.2 (now 2.5.3) installed.
If the issue with BusyCal arises again, a less drastic solution is to go to BusyCal > Preferences > Appearance and uncheck "Animate Transitions". This is what caused the problem in previous versions.
 
Comment

Sir Al

macrumors member
Feb 14, 2005
98
1
Vancouver, Canada
I can confirm that deleting BusyCal 1.6.3 that was on my hard drive, fixed it. Just trashed it and ran 'killall Dock' in the terminal, and voila!

Check if you have BusyCal somewhere on your hard drive, it doesn't have to be in the Applications folder. If Spotlight can find it, chances are its impacting your battery life.

This is still an Apple bug as an App shouldn't do something like this, especially if it's not running. Let's hope the Info.plist change makes its way into 10.9.1. I wonder how many users are having their battery life significantly reduced because of this without them even realizing it?
 
Comment

tivoboy

macrumors 68040
May 15, 2005
3,133
212
I know this is an old thread, but is there a fix for this? I upgraded to yosemite yesterday (from ML) and I have this dGPU issue I DO have busycal 1.6.4 installed, but don't want to delete it. Is there some other way to get it to not use the dGPU?
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.