OSX 10.9 does not sleep

Discussion in 'OS X Mavericks (10.9)' started by cutter74, Feb 2, 2014.

  1. cutter74 macrumors member

    Joined:
    Nov 15, 2012
    #1
    I recently noticed that after upgrading my Mac Mini (late 2012) to Maverick, for some reason, the energy saver options do not seem to kick in and the computer never sleeps. All energy saver options are set to default, the Monitors enter the power saving mode at the predefined time (10 mins), but the Mac Mini never sleeps. If I manually select "Sleep" from the OS menu, the PC sleeps just fine but I would really like to get my Mac Mini to sleep automatically after 10 mins of inactivity. Any ideas on how to find the reason/process/application that stops my Mac Mini from sleeping according to the Energy Saver settings?
     
  2. VanillaCrackerC macrumors newbie

    Joined:
    Jun 8, 2013
    #2
    type in terminal: pmset -g assertions
    and you will see what could prevent sleep
     
  3. davidlv macrumors 65816

    Joined:
    Apr 5, 2009
    Location:
    Kyoto, Japan
    #3
    Using pmset -g alone will show "sleep prevented by AddressBookSour" (Address Book Source ...), and setting up your iCloud account in the System Preferences Pane will clear that up i.e. pmset -g will not show that message, and sleep will work again.
    I firmly believe this is not a (good) feature, as there are many good arguments possible against using the cloud at all (government access etc. included), and preventing sleep in any form on a laptop is definitely not good. Closing the lid does work, even when that "sleep prevented by AddressBookSour" msg appears, but the automatic timeout doesn't (as shown with the pmset -g assertions suggestion above).
    Prior versions of OS X didn't (as far as I know) have this "built in" dependancy on having an iCloud account set up, and I don't like this trend at all.
     

Share This Page