OSX and New SSD

Discussion in 'macOS' started by ddubois89, Sep 4, 2011.

  1. ddubois89, Sep 4, 2011
    Last edited: Sep 4, 2011

    ddubois89 macrumors newbie

    Joined:
    Sep 4, 2011
    #1
    I just bought a new 60GB SSD. Its an OCZ Vertex Plus. Here are the Specs.

    http://www.newegg.com/Product/Product.aspx?Item=N82E16820227738

    Well anyway, I own a Black 2007 Macbook and decided to upgrade since the ssd was cheap and I didnt need my 250GB Hdd in there anyway.

    I tried installing 10.6 SL on the drive and everything seemed to work until after the welcome video. It made me set up my account and register, and then when the OS is supposed to actually boot to the desktop it doesnt and I just get the pinwheel. I left it there for about 30 Min, then just decided to wipe and try again to no avail. After the 3rd time I decided eff it.

    I got a OSX Lion Usb Drive and tried doing that. Lion gets to the process where it restarts, then starts installing. I then receive a No Recovery Error, where it tells me a Recovery cant be created then proceeds to cancel the install. The only way to get the drive to even try and install again is to restart, clear the PRAM and try again. Which gives me the same error.

    My macbook has been running fine, I feel like its my drive that is bad but I was able to get it to recognize and format fine in Windows. I figure maybe someone had a workaround or similar problem? My next step is to try it on a different mac using Target Disk Mode and see if that helps.

    Any advice/help is greatly appreciated. I will answer in the morning when I wake up. I was pumped to finally have an SSD regardless of the speed of smaller random writes etc, I never thought I would have this much trouble. :(


    PS: Looks like I have latest FW of 3.02.
     
  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    Before you installed OS X, how did you partition/format the new drive? You need to set it up as a GUID Parition Table and format as Mac OS Exteneded (Journaled).
     
  3. ddubois89 thread starter macrumors newbie

    Joined:
    Sep 4, 2011
    #3



    Sorry, Left that part out. I did format as OS Extended Journaled and used GUID Partition table.
     
  4. ddubois89 thread starter macrumors newbie

    Joined:
    Sep 4, 2011
    #4
    My old HDD is installing lion just fine, so I may have a defective SSD. Im going to try and make a backup from the HDD and restore from the backup to the SSD.

    This Sucks.
     
  5. fwclements, Sep 7, 2011
    Last edited: Sep 7, 2011

    fwclements macrumors newbie

    Joined:
    Sep 7, 2011
    #5
    Me also

    I also just picked up the same SSD. Trying to install either 10.6 or 10.7 fails eventually. I did the following:

    Installed the new drive, booted the old drive via USB. From disk utility formatted ("Erased") the SSD and created a single GUID partition. Ran some write tests against it - everything works fine. Reboot - the partition disappears.

    Interestingly ... if you erase the drive, and partition it and then immediately run First Aid on it it reports all sorts of errors on the disk. I read in another post somewhere else that someone attempted hooking up the SSD with USB and this worked fine. Another post mentioned that this drive is "to fast for OS X" and there is an "apple optimized" version which is down clocked. Not sure how true this is though.

    Semi-relevant post: http://www.ocztechnologyforum.com/wiki/index.php?title=How_to_set_up_Mac_OS_X_on_a_VERTEX

    More info on IDE vs AHCI mode: http://www.ocztechnologyforum.com/f...mware-upgrade-workaround-(Linux-iMac-no-AHCI)
     

Share This Page