"OSX can't be installed because a recovery system can't be created."

Discussion in 'OS X Mountain Lion (10.8)' started by carrerascott, Jul 25, 2012.

  1. carrerascott, Jul 25, 2012
    Last edited: Jul 25, 2012

    carrerascott macrumors regular

    Joined:
    Mar 18, 2009
    #1
    I'm getting this error trying to install ML. I'm installing to a 512GB SSD drive with 74GB free. The error message during install says to go to apple/com/support/no-recovery -- but that page doesn't seem to cover the issue at all?

    I checked in Disk Utility and the disk is Mac OS Extended (Journaled).

    I am not using RAID and do not have a Boot Camp partition installed... (since that support page references those as issues...)

    Any tips?


    Mac Pro 5,1
    OSX 10.7.4
    32GB RAM
     

    Attached Files:

  2. 1stdaz macrumors newbie

    Joined:
    Jul 16, 2012
    #2
    Same problem here. I can't restore USB stick with InstallESD.dmg.
     
  3. Winter Charm macrumors 6502a

    Winter Charm

    Joined:
    Jul 31, 2008
    #3
    I had the exact same issue with my mac mini :( I'm stuck. I've tried various things, but now the installer is just stuck :(
     
  4. atlisd macrumors newbie

    Joined:
    Mar 13, 2011
    #4
  5. finao12 macrumors newbie

    Joined:
    Jul 25, 2012
    #5
    quick fix

    I had the same problem, it appears to be happening to people who have installed an SSD of their own. I simply had to resize my Mac HD partition (does not delete any of your data) by making it 1GB smaller. Then I ran the installer again and it worked fine. All this does is give the installer room to create a Recovery System during the install process. Writing this from Mountain Lion.
     
  6. Winter Charm macrumors 6502a

    Winter Charm

    Joined:
    Jul 31, 2008
    #6
    I can confirm that deleting the Lion recovery partition is how you fix this issue :D

    I still have my bootcamp install, and it worked just fine :)
     
  7. Senator48 macrumors newbie

    Joined:
    Jul 26, 2012
    #7
    Did deleting the the Lion Recovery HD partition damage or delete any of the data on your main partition? Looks like I'm having the same problem, but I wanted to make sure that I won't lose anything in the process. Thanks!
     
  8. comcipher macrumors newbie

    Joined:
    Jul 30, 2012
    #8
    THANK YOU!

    I've been trying to get Mountain Lion installed for the past 4 hours, with endless problems around the recovery disk. Long story short, I have an SSD installed in my early 2011 MBP running Lion, and the recovery partition must have somehow not been cloned over properly. Disk utility showed an Apple_Boot partition, but without any name (which should be Recovery_HD).

    Deleting that partition and merging it with my main "Mac SSD" partition did the trick, following this guide http://osxdaily.com/2011/06/30/deleting-the-mac-os-x-10-7-lion-recovery-hd-partition/ , specifically the section "Deleting and merging a partition with diskutil from the command line".

    After the delete and merge, Mountain Lion installed without any hassle at all. Hopefully others find this helpful as well!
     
  9. sharkash macrumors newbie

    Joined:
    Jan 14, 2013
    #9
    Worked like a charm :)
    btw I got this error even though i hvnt changed the harddisk on my mac (its still a disk drive). All I did was reformat the disk and install Snow Leopard from the CD, before trying to upgrade.
     
  10. coffeecup macrumors newbie

    Joined:
    Jun 10, 2013
    #10
    Even with 2nd drive?

    I am having this same problem, needed a clarification:

    I have early 2012 Macbook Pro, so it came with Lion on the harddrive, which I upgraded to ML.

    I have installed a second drive, the SSD, which I am trying to install ML onto but cannot due to the no-recovery error.

    The SSD does not have a recovery partition (I checked) although the harddrive does.

    So would deleting the recovery partition on the hard drive work, although it is not the drive I am trying to install ML to?
     
  11. Matty1 macrumors newbie

    Joined:
    Mar 30, 2014
    #11
    I had this exact error when trying to upgrade Mac OS 10.7.5 to OSX Mavericks. I have Win 7 Pro boot camped.

    I followed these instructions and deleted the recovery partition but wasn't able to successfully merge my main Mac OS partition with the deleted partition. Now I can't boot into Mac OS at all. When I hold down the Option button while booting, there is no longer an option to boot into Mac OS - only Windows. When I boot into Windows, I can see my Mac OS partition and the deleted blank partition in explorer. How do I recover from here firstly so that I can boot into OSX and secondly merge the deleted partition and update to Mavericks?
     

Share This Page