OSX El Capitan and Java Version 8 Update 60

Discussion in 'OS X El Capitan (10.11)' started by tanujmehta26, Oct 6, 2015.

  1. tanujmehta26 macrumors newbie

    Joined:
    Oct 6, 2015
    #1
    Hi All,

    I just upgraded to El Capitan. After successfully installing it, the first thing I see is 'To use the"java" command line tool, you need to install a JDK' (Attached File 1)


    1.png



    I then installed the java update. (Attached File 2)

    2.png



    Next it prompted me to verify the java update. (Attached File 3)

    3.png


    After that I successfully verified the Java version. (Attached File 4)

    4.png

    On restarting my computer, I got the same message as I did when I first installed the new OS X. I un installed and re installed the java update 3 times, and it still gave me the same error each time. (Attached File 5)

    5.png


    If any one has any idea on how to fix this, please do let me know.

    TIA

    Tanuj
     
  2. Sko macrumors regular

    Sko

    Joined:
    Oct 17, 2009
    Location:
    Germany
    #2
    The JDK (Java Development Kit) is available on Oracle's website. Java website only gives you the JRE (Java Runtime Environment).
     
  3. tanujmehta26 thread starter macrumors newbie

    Joined:
    Oct 6, 2015
    #3
    Thank you for your reply. I have no idea why the error dialog box would lead me to download JRE when it clearly says I need to download the JDK. Anyway, thanks to your tip I have been trying to download the dmg file from Oracles' website. For some reason the connection times out after downloading about 10 mb of 227 mb file. I tried downloading on 2 different macs (10.9.5 and El Capitan), using 2 different browsers (Safari and Chrome) on 2 different networks but end up with the same results each time. Anyone else experiencing this issue?


    Screen Shot 2015-10-06 at 4.52.57 pm.png


    Screen Shot 2015-10-06 at 4.52.00 pm.png
     
  4. Floris macrumors 68020

    Floris

    Joined:
    Sep 7, 2007
    Location:
    Netherlands
    #4
    I installed java 8u60, netbeans, and JDK without any problems on ELC
     
  5. enakeprimen macrumors newbie

    Joined:
    Jan 17, 2012
    Location:
    Jakarta, INDONESIA
    #5
    No issue with me also. Probably you need to check your internet connection stability.
     
  6. lomojunkie71 macrumors newbie

    lomojunkie71

    Joined:
    Oct 10, 2015
    Location:
    Shelton, Connecticut
    #6
    Thank you. This solved my issue.
     
  7. thericker52 macrumors newbie

    Joined:
    Jan 31, 2015
    #7
    I have a MacBook Pro, also running El Capitan and I updated the most recent version of Java, which is Java 8, update 91 and I get the same message you are getting. My system shows I have the latest Java update, but I keep getting this message popping up very often. If anyone can help it would sure be appreciated.
     
  8. treekram macrumors 6502a

    Joined:
    Nov 9, 2015
    Location:
    Honolulu HI
    #8
    If you read through all the posts, you need to make sure you download the JDK, not the JRE. Specifically look at posts #2 and #3. If you believe you installed the JDK, you can run the "Terminal" program and type in "javac" on the command line and press the Return key. If it's installed properly, you'll get a screen full of information starting with "Usage: javac <options> <source files>". Otherwise, you'll get a "command not found" message. If you have the JDK installed and still are having issues, let us know.
     

Share This Page