OSX hanging all the time but doesn't in safe mode

Discussion in 'macOS' started by teapea, Apr 11, 2010.

  1. teapea macrumors newbie

    Joined:
    Apr 10, 2010
    #1
    Okay the last 24 hours I have been having major problems with my July 2009 13" MBP (4gb ram / 500gb hdd)
    It's been barely usable just getting the spinning beach ball of death for a min or so then it will work again for a few mins then dies again, it won't even open most applications, I thought it was a hardware problem to tried taking out each RAM stick, didn't work, really starting to tear my hair out thought maybe it was a HDD problem. as it took an age just to even boot.

    Then today I booted into safe mode and all is well, it's running as normal in safe mode... So I'm thinking it's maybe a software problem, but I have no software login items as I took everything off already.
    So it must be something that runs in normal mode but not safe mode that's doing it,
    Is there anyway I can find out what it is?
    I was thinking of formatting then restoring from my time machine backup but I'm guessing that will restore all the applications too? Plus it's a major faff reinstalling all my software than plugins for software etc,
    Was wondering if anyone had any idea,
    Thanks,
    Tom :confused:
     
  2. mbpcron macrumors member

    mbpcron

    Joined:
    Jun 23, 2007
    Location:
    Richmond, VA
    #2
    I guess you've tried the usual suspects

    Resetting permissions, resetting pram and nvram. Removing third party apps. Running diagnostics on your harddrive, etc?
     
  3. Hal Itosis macrumors 6502a

    Hal Itosis

    Joined:
    Feb 20, 2010
    #3
    Have you tried booting back normally since doing that Safe boot? There's a chance —if the problem was a dirty cache file (font database or something) —that the Safe boot may have removed it. I.e., when you boot normally, a clean cache will be created.



    Well, you can just look in System Prefs for 3rd-party stuff. There are also Terminal commands that can list 3rd-party extensions or prefPanes...

    kextstat |grep -v com.apple


    system_profiler SPPrefPaneDataType |
    grep -A2 -B3 3rd |sed '/3rd/d;/./!d'

     
  4. teapea thread starter macrumors newbie

    Joined:
    Apr 10, 2010
    #4
    Got it, it was "little snitch" once I uninstalled that everything was well in the world again,
    Thanks for the replies guys :D
     
  5. Hal Itosis macrumors 6502a

    Hal Itosis

    Joined:
    Feb 20, 2010
    #5
    That's strange... i've been using Little Snitch since day one, and it's never caused any issue.

    Are you using LS version 2.2.2 with OSX 10.5.8 or how?
     

Share This Page