osx lion 10.7 Wake on lan not working

Discussion in 'Mac OS X Lion (10.7)' started by locojay, Jul 22, 2011.

  1. locojay macrumors newbie

    Joined:
    Jun 21, 2010
    #1
    hi WOL does not work on osx lion.

    I tried this using ddwrt or using apple remote.

    putting machine (2010 MP) to sleep under apple remote desktop works but waking up does not.

    under energy saver i have wake for network access checked

    waking up using keyboard works but i need to have the ability to use wol
    any idea?


    many thanks
     
  2. amityweb macrumors member

    Joined:
    Oct 5, 2010
    Location:
    Wales
    #2
    Same here... In SL I could always see my computer in Apple TV and my Splashtop desktop connection app in the iPad. Following upgrade to Lion, when it goes to sleep I cannot see it in Apple TV or my desktop connection app. As it's two floors up it's quite a chore to wake it up every time I need to stream from it in ATV.
     
  3. amityweb macrumors member

    Joined:
    Oct 5, 2010
    Location:
    Wales
    #3
    I have an update.. With SL I used Ethernet and turned Wifi off. Now I have lion, I noticed wifi was on aswell as Ethernet. Would lion turn wifi on when it installed?? Since using either one of wifi or Ethernet I can stream to AppleTV and see my computer in my remote desktop app, and the apple remote app works too. So I wonder if having both wifi and Ethernet caused this issue, and lion turned wifi on?
    *
    I have not left my computer alone long enough to see what happens after the hard drive goes to sleep, but it looks more promising than before.
     
  4. nOw2 macrumors regular

    Joined:
    Sep 1, 2009
    #4
    Lion switched on WiFi on both desktop machines I've installed on.
     
  5. amityweb macrumors member

    Joined:
    Oct 5, 2010
    Location:
    Wales
    #5
    I think this was one of my issues, its been fine now I have disavled wifi and stick with ethernet as it was before the upgrade.

    As for the sleep issue... I have had to set Computer Sleep to Never. Now the issue is fixed. The thing is, I dont remember setting it in SL. So either it worked OK in SL even when in Sleep, Sleep did not work in SL, or Lion set it to 30 minutes when I upgraded. Either way, something has changed, but I fixed it by Never putting the computer to sleep.
     
  6. dmelgar macrumors 68000

    Joined:
    Apr 29, 2005
    #6
    I'm also trying to get the fabled wake up on network activity to work.

    Telling it never to sleep hardly fixes the waking up problem.

    Is this supposed to work? Do you need to have an Apple router?
     
  7. pbrooks macrumors regular

    pbrooks

    Joined:
    Jul 15, 2008
    #7
    It's working for me with no special trips to System Preferences.
     
  8. pbrooks macrumors regular

    pbrooks

    Joined:
    Jul 15, 2008
    #8
    When you say WOL doesn't work, are you not able to discover the remote computer at all? It's working perfectly for me without any reconfiguration after installing Lion. Are you sure you're not experiencing the new "low-power wake" feature?

    I copied this from Apple's Lion site...

    Low-power wake
    In OS X Lion, your Mac can wake up for services such as file sharing, backup, and more without the need to turn on the monitor or attached USB devices.

    This is a great idea.
     
  9. amityweb macrumors member

    Joined:
    Oct 5, 2010
    Location:
    Wales
    #9
    No it does not work for me.... if Computer Sleep is set (I had 30 minutes) once this happens you cannot see the computer in AppleTV, Apple Remote, Crashplan Backups, SugarSync, or VNC/Splashtop Streamer (I did not try anything else). I waited to see if the computer wakes up but it did not. This occurred on Wifi and Ethernet. I have the setting to wake on network.

    I am sure in Snow Leopard I did not changed the setting for Computer Sleep to Never (I may be wrong though). I am sure it was the default and it just worked. I have two iMacs, one at home and the office and they were the same (although Home was copied from Work). If I did change it then Lion changed it back.

    But I am now concerned about having the computer always on.
     
  10. Smacky macrumors 6502

    Joined:
    Jul 23, 2008
    #10
    Yeah wake on wifi is broken
    Lion truly is a pice of s*#t :mad:
     
  11. amityweb macrumors member

    Joined:
    Oct 5, 2010
    Location:
    Wales
    #11
    Wake on Ethernet not working for me either.

    I like Lion, I prefer Mission Control and am going to get used to the reverse scrolling which makes sense actually, and because all I use is OS X and iOS. But it does have its issues, not just these I reported but a few other glitches.

    You will get this with any new OS released I think, the test is how quick they will fix and release updates :)
     
  12. basher macrumors 6502

    basher

    Joined:
    May 27, 2011
    Location:
    Glendale, AZ USA
    #12
    I had the same issues as the OP. Fixed, for me anyway, by turning off WiFI on my MBP. WoL just fine when the MBP is running a wired network connection.
     
  13. Celeron macrumors 6502a

    Joined:
    Mar 11, 2004
    #13
    Wake is working fine for me. Both wired and wireless. I found that wake over wireless only works if my MacBook Pro is sleeping with the screen open. If I put it to sleep by closing the lid it won't wake up. If I put it to sleep, with the screen open, via the menu, it works fine.

    I have an Airport Extreme base station which operates as a bonjour sleep proxy so it handles the actual wake on LAN packets.
     
  14. Psilocybin macrumors 6502a

    Psilocybin

    Joined:
    Jan 16, 2011
    Location:
    Ontario, Canada
    #14
    Mine doesn't function at all on my wired iMac
     
  15. pumpkinwhite macrumors member

    Joined:
    Sep 3, 2006
    #15
    WOL works in Lion but only in low power mode.

    WOL (over ethernet) in Lion seems to be waking up the computer only in low power mode. Only apple services (like file/printer sharing etc.) turn on, but the computer everything else (any applications running) remain off. I can see the computer on my home file sharing network, but any applications remain off.

    I think this is why some people are thinking that WOL is not working. Visually on my MBP only thing that changes is the blinking front light turns off. This is a 'feature' in Lion (low-power wake).

    The problem is I don't want to use the 'low-power wake' feature. I want to remotely log into my mac via logmein or teamviewer. Those apps do not start till you hit a key on the keyboard, and the computer wakes fully.

    Any way to turn-off the 'low power wake'?
     
  16. InfiniteLoop macrumors member

    Joined:
    Nov 13, 2005
    #16
    I am on wired on my new Mini and it will wake up for some, but not others. For example it will wake up when I try to ssh to my mac. But it will not wake up when I try the access a web page I am hosting on it. I am wondering if it is possible to configure it so that I can select the TCIP ports to wake up on?
     
  17. Rhuston502 macrumors newbie

    Joined:
    Aug 5, 2011
    #17
    I'd also like to know how to disable low power wake. Seems that there is no way to WoL remotely to use Teamviewer until we figure out how to disable it.
     
  18. soundbyte macrumors newbie

    Joined:
    Aug 8, 2011
    #18
    Log Me In Fail

    JUst got this from customer support at Log Me In:

    Thank you for contacting LogMeIn. The LMI software does not have the ability to wake up a computer unless if qualifies for the WAK on Lan features. So you will have to make sure you change the sleep settings on your host computer.

    Guess they haven't heard about Low Power Wake.

    So just how much power is 32" iMac using when it's awake?
     
  19. saberahul macrumors 68040

    Joined:
    Nov 6, 2008
    Location:
    USA
    #19
    Has anyone had any luck with this? I can no longer find the setting for WOL on my MBP and LogMeIn will no longer wake my laptop up when it is sleeping... help?
     
  20. basher macrumors 6502

    basher

    Joined:
    May 27, 2011
    Location:
    Glendale, AZ USA
    #20
    Go to System Preferences, Energy Saver. There you'll see "Wake for network access"
     
  21. saberahul macrumors 68040

    Joined:
    Nov 6, 2008
    Location:
    USA
    #21
    Okay thanks, I was looking there but under the Battery Option and it only seems to show for Power Adapter Option. It was already checked and last night I tried LogMeIn again while computer was plugged but LogMeIn shows it as offline. On SL, I used to see the computer as "sleeping" and had the option to turn it on. This doesn't seem to be true for Lion... anyone get it to work?
     
  22. 41114 macrumors newbie

    Joined:
    Sep 8, 2011
    Location:
    NL
    #22
    Solution (at least for me)

    In the network preferences pane, setting all the options to 'inactive' except the one to use does the trick for me. Wakes up perfectly over lan, didn't try over the net though...

    [​IMG]
     
  23. Smacky macrumors 6502

    Joined:
    Jul 23, 2008
    #23
    Will give this a try and report back in a few days
     
  24. Inked macrumors regular

    Joined:
    Feb 15, 2009
    Location:
    Buckinghamshire, UK
    #24
    Tried it this morning, working so far.

    Cheers
     
  25. Smacky macrumors 6502

    Joined:
    Jul 23, 2008
    #25
    Didn't work for me unfortunately. Made the change, rebooted and let it sleep overnight. Next morning couldn't wake it over wifi with my MBP. Seems its the duration of sleep which determines whether it will wake or not
     

Share This Page