OSX ML Server on a DIY MacMini Fusion Drive

Discussion in 'Mac mini' started by eyepea, Mar 15, 2013.

  1. eyepea macrumors member

    Joined:
    Jul 20, 2012
    #1
    Just a word to the wise, I have a 2012 MM i7 Quad 2.6Ghz with a fusion drive made from an OCZ Agility 3 240GB and the original Hitachi 1TB that came with the MM.

    The fusion drive and OSX all go really well with no problems with anything, but I am having problems with OSX ML Server when I try to share the fusion drive. I have had three goes now and will give up as it is not absolutely required for me to share the fusion drive.

    Basically Server never finishes propagating permission and just hangs, when I eventually reboot, the OS wont boot.

    There may be ways around it but I dont really care too mush as I don't need to share the Fusion drive so much.

    I just thought I would mention to proceed with care when running OSX ML Server on a Fusion setup. I don't think they were designed for each other.

    I only use Server for HD sharing so I am going to use the share options in OSX and do away with Server.

    IP
     
  2. MatthewAMEL macrumors 6502

    MatthewAMEL

    Joined:
    Oct 23, 2007
    Location:
    Orlando, FL
    #2
    Are you sure it's a Fusion Drive issue?

    What is the error message Console is reporting?
     
  3. eyepea thread starter macrumors member

    Joined:
    Jul 20, 2012
    #3
    I dont have the error report.code because I have reinstalled OSX.

    Basically each time I tried to create a sharepoint with the whole 'Macintosh HD' Fusion drive, Server just hung and never completed the 'saving sharepoint setting' part. When I tried to propagate permissions the Drive Genius 3 App went nuts telling me Macintosh HD is corrupt and to run a repair. So eventually I have to force quite server and when I restart OSX just hangs at the grey screen with the apple and little twirling thing. I tried repairing permissions/disk etc with an external Disk Utility on a separate boot drive and Repair Disk in Disk Utility says the core storage image is corrupt and cannot be fixed. It says please backup all data and rebuild the drive.

    It happened twice. I accept I should not force quit server but it was going no were so I had to.

    Anyway, I only use server for sharing files so I don't need it. I will just use the OSX sharing options as they are the same for what I want.

    I am not too concerned about a fix because I won't be trying it for the third time. But I thought I would mention it for interest.

    To answer you question, is it a fusion drive issue? Well half a dozen of one and 6 of the other... I think Server instigated it but certainly the Fusion drive is shot when I access it via an external Disk Util GUI.
     
  4. eyepea thread starter macrumors member

    Joined:
    Jul 20, 2012
    #4
    Just an addition to my post, I had a look on the apple site and notice the server model of the MM does not give you the option for a fusion drive, nor can you take an option of an SSD and HDD. You can only get 2 HDDs, 1 SSD, or 2 SSDs.

    At least this is the case with the Aus Apple site.
     

Share This Page