OSX not discovering flash drive, but XP in Parallels is?

Discussion in 'Windows, Linux & Others on the Mac' started by petrucci666, Dec 7, 2009.

  1. petrucci666 macrumors 6502a

    Joined:
    Apr 30, 2009
    Location:
    San Francisco, CA
    #1
    I've had this problem the other way around before but I somehow got it to work before on both operating systems simultaneously. Now, my USB flash drive is found without a problem in XP, but OSX will not find it. I've tried cleaning both the flash drive and USB port, as well as trying multiple ports, and I'm plugging it in directly into my MBP, not using USB hubs.

    Anyone know what I could try to fix this? I need the flash drive present on both systems
     
  2. StruckANerve macrumors 6502

    Joined:
    Dec 31, 2008
    Location:
    Rio Rancho, NM
  3. CylonGlitch macrumors 68030

    CylonGlitch

    Joined:
    Jul 7, 2009
    Location:
    SoCal
    #3
    My guess is that it has been formatted NTFS, try using windows to reformat it and make sure you have it set to FAT32.
     
  4. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #4
    Typically if you have a virtual machine, the default behavior is set so only one of them will recognize the removable drive.

    You might want to change the settings / read the manual of parallels.
     
  5. balamw Moderator

    balamw

    Staff Member

    Joined:
    Aug 16, 2005
    Location:
    New England
    #5
    Even on a Leopard system it would show up as read only if it were just NTFS.

    I concur. In VMWare at least, if the USB flash drive is grabbed by OS X it is not visible to Windows and vice/versa. Ejecting it from Windows usually makes it show up in OS X.

    The manuals may have some suggestions, but if not. Your best bet is to mount in in OS X and set it as a shared folder in Parallels so under Windows it would be seen as a network drive.

    B
     

Share This Page