OSX not recognize Boot Camp partition as NTFS, but as FAT when it really is NTFS

Discussion in 'Windows, Linux & Others on the Mac' started by tarngerine, Jul 24, 2010.

  1. tarngerine macrumors newbie

    Joined:
    Jul 24, 2010
    #1
    OSX does not recognize the NTFS partition of Boot Camp Windows 7 I have.
    It is not mounted in Finder.

    I went to Disk Utility to see the NTFS partition, the one I installed my Windows 7 on, but it says the format is in MS-DOS(FAT) whereas I clearly see it shows as NTFS on Windows 7. It is also greyed out, named disk0s3.

    I tried to verify the disk and it fails as follows:

    Verifying volume “disk0s3”
    ** /dev/disk0s3
    Invalid BS_jmpBoot in boot block: fcfcfc
    Error: This disk needs to be repaired. Click Repair Disk.

    Even when I click repair disk, it fails and says I have to reformat.

    VMWare cannot access the Boot Camp drive due to this issue.

    What is the appropriate action? Everything from the Windows 7 end works perfectly (I can read from the Mac partition, Boot Camp Utility works great), but OSX (running latest 10.6.* SL) sees the drive as MS-DOS. It is not listed under Startup Disks (in OSX), and does not mount.

    This was posted 2 weeks back by someone else and was unsolved (http://forums.macrumors.com/showthread.php?p=10638168#post10638168) but I wanted to try in this forum instead.

    Things I've tried:
    -Winclone does not work. OSX does not see the partition as NTFS.
    -Cannot backup Windows 7 as a System Image because my external is not NTFS
    -Heard about Casper 6, but having a hard time finding a torrent for it.

    Is there anything I can do besides reformatting? My Win7 only has 2 more activations left.
     
  2. TOGGI3 macrumors newbie

    Joined:
    Aug 1, 2010
    #2
    Same exact problem, I am dying for a fix here.
     
  3. umiwangu macrumors 6502

    Joined:
    Sep 4, 2006
    Location:
    Malawi
    #3
    Have you tried running chkdsk in Windows?

    And as for activations, won't it recognize that you're installing Windows on the exact same computer as before? At least that's that XP used to do (unless you changed too many components)...
     
  4. balamw Moderator

    balamw

    Staff Member

    Joined:
    Aug 16, 2005
    Location:
    New England
    #4
  5. samth3mancgp macrumors newbie

    Joined:
    Aug 29, 2012
    #5
    Is there any known fix for this? I am having the exact same problem and have read a bunch of other threads about it. I don't want to have to reformat and start all over :(

    Sorry for bumping an ancient thread.
     
  6. murphychris macrumors 6502a

    Joined:
    Mar 19, 2012
    #6
    I don't understand why people even remotely expect a Mac OS X disk repair utility to be capable of repairing a Windows file system.
     

Share This Page