OSX problem with Wireless Hotspot (captive portal)

Discussion in 'macOS' started by s13, Sep 18, 2009.

  1. s13 macrumors newbie

    Joined:
    Sep 18, 2009
    #1
    Hello all,

    We recently deployed a new public wireless system here at work, and a couple of our patrons who use Macs have been unable to use it. First, a little tech background - the system uses an array of WRT54GL routers running DD-WRT and using Chillispot+RADIUS for authentication. As with many other systems of this variety, users open their web browser and get redirected to our login server instead of their homepage. We've had the system live for about two months now and it has worked flawlessly on nearly every machine - all versions of Windows from 2000 all the way up to 7, several flavors of Linux, and most Macs as well.

    However, as of today we now have two patrons (both running Leopard) who cannot access the system. Airport finds the network fine and gets a proper DHCP lease, but upon opening the browser, all we can get is "cannot connect to [login server]." It's not a browser-specific issue either, it happens under both Safari and Firefox. I've gone through all of the TCP settings on both of these machines without success. I don't think it's a DNS-related problem because the proper DNS servers are given to the machine via DHCP, and even if they weren't, the login server is accessed via IP rather than hostname so DNS should be irrelevant at this stage. One of the guys even disabled his firewall to see if that was the cause (as has been the case on some Windows machines) but that didn't help either. Both guys said they have no trouble accessing other wireless networks, though neither mentioned if any of those networks had captive portals.

    So, OS X faithful, any thoughts or suggestions? I have now done several hours worth of Googling on this subject and have yet to come up with a resolution.
     
  2. Tairon macrumors newbie

    Joined:
    Jul 21, 2008
    #2
    Same problem

    I'm having this problem as well, but so far I'm blaming Snow Leopard. I previously had no problems joining captive portals at public hotspots, but since I upgraded to SL I run into the same problem you described, and so far no clues as to what the problem is. Hope someone can help.
     
  3. rshrsh macrumors newbie

    Joined:
    Oct 9, 2009
    #3
    Same problem also

    Upgraded to Snow Leopard and the same connection problems began. The hotspot is using a similar system as mentioned above.
     

Share This Page