OSX Server, Calendar Service, Locations and Resources with iOS

Discussion in 'Mac OS X Server, Xserve, and Networking' started by Ernsti, Aug 7, 2015.

  1. Ernsti macrumors newbie

    Joined:
    Aug 7, 2015
    #1
    I have a mac mini with OSX 10.10.4 and Server 4.1.3 with an activated calendar service.
    Basically it works perfectly.

    Yesterday i tried the function "Locations and Resources".
    I created 2 locations "Living room","kitchen" and 2 resources "Playstation", "Oven".
    Then i created a new event on my iMac (OSX 10.10.4) and on my MacBook (OSX 10.10.4) with the new created locations and resources and it works perfect.

    After that, i tried it on a iPad (iOS 8.4).
    I created an new event. I could select a location perfectly (with intellisense) but i could NOT select a resource (no intellisense....). So I typed the name of the resource "Playstation" by Hand. If i try to save to event i got the errormessage "'' is not a valid e-Mail address".

    Please help me, because i dont know whats the problem.

    ps:
    sorry for my bad englisch.
    many greetix from austria.
     
  2. Cybaru macrumors newbie

    Cybaru

    Joined:
    Aug 12, 2015
    Location:
    Iowa
    #2
    Based on "some things" that I've seen in "dark corners" of Apple's website, and based on a conversation I had with "a source," iOS 9 should bring enhanced support for these types of features. This includes enhanced support for resource delegates.

    Sorry I can't be more helpful. I've struggled to get those features to work for years. They're great on my Mac... but I typically need to do scheduling/calendaring when I'm out-and-about with my iOS devices.
     
  3. jakelong macrumors newbie

    Joined:
    Sep 21, 2015
    Location:
    Irvine, Ca
    #3
    The problem is you have to choose the OS X Server calendar first then the resources/locations will appear for you. So you click the plus + sign first then scroll down to were it says calendar, click that, change it to the OS X server calendar, then scroll back up to location and start typing. Your locations will pop up under "conference room".

    Hope that helps!
     
  4. Ernsti thread starter macrumors newbie

    Joined:
    Aug 7, 2015
    #4
    Thank you for your answers.

    I choosed the OSX Server calendar first. I CAN select a Location (e.g. "conference room"), so Locations are working perfect.
    But If i enter a name of a resource defined on OSX-Server in invitees i get the message "'' is not a valid e-mail adress" and the resource is NOT found.....

    It is also not working after updating to iOS 9

    On an second iMac it works perfect !

    summarized:

    - Locations are working well and perfect on iOS
    - Resources are NOT working on iOS8/9


    Thank you.
     
  5. jakelong macrumors newbie

    Joined:
    Sep 21, 2015
    Location:
    Irvine, Ca
    #5


    For some reason the resources only work with the calendar if you do it through the webcal. So you go to your server via Internet browser and your wiki has to be turned on in the server application. Once you sign in click calendar at the bottom and you'll get a calendar screen. Next to your name or the calendar name at the top there will be a little upside triangle. When you click that your resources will show up in the drop down menu.

    Definitely something Apple needs to fix.
     
  6. Ernsti, Sep 22, 2015
    Last edited: Sep 22, 2015

    Ernsti thread starter macrumors newbie

    Joined:
    Aug 7, 2015
    #6
    Thank you for your answer.

    I tried to access to the resources via webcal and wiki.
    I can open the calendar, i can see the little triangle next to my name, but i am not able to click on it (I'm connected from a Windows-PC with Firefox over Internet and VPN), but i can open the source code of the triangle and here i can see all of my resources:

    <span>Kalender für Ernsi<span class="popuphandle">▼</span><select><option value="__">Mein Kalender</option><option value="/principals/__uids__/FF9B203-3346-4DD5-????-4787FFF2BE1B/">Wohnzimmer</option><option value="/principals/__uids__/DD407053-????-4133-BCFF-04E1FB9D????/">Ofen</option><option value="/principals/__uids__/6FF0DD23-AD99-4012-BFE4-B56DD????C92/">Küche</option><option value="/principals/__uids__/55F2D0DD-AB33-43D9-????-EDDD15CEBFF7/">Playstation</option></select></span>

    Translation:

    Wohnzimmer = Livingroom
    Küche = Kitchen
    Ofen = Oven
    Playstation = ?


    Thank you.
     
  7. jakelong macrumors newbie

    Joined:
    Sep 21, 2015
    Location:
    Irvine, Ca
    #7

    You have to use safari as the browser. OS X server wiki/WebDAV isn't compatible with any other browser. (Apple likes to force you into the family haha) hope that helps!
     
  8. Ernsti thread starter macrumors newbie

    Joined:
    Aug 7, 2015
    #8
    Oh thanks for the hint, i forgot..... I'm at work at the moment and i dont have a mac here.....

    thank you.
     
  9. Ernsti thread starter macrumors newbie

    Joined:
    Aug 7, 2015
    #9
    Today i created a new Calendar-entry in OS X with Location "Living room" and the resource "Playstation" as invitee.
    Then i could see the resource "Playstation" in Invitees on the iphone-calendar with a green checkmark !

    Then i copied the name of the resource "Playstation" on the iPhone and pasted it in new and then i saw following:
    urn:x-uid:55F4A2D0-AB33-43D9-9075-E45235CEBBD7 with a checkmark at the beginning !

    if i change one of the hex digits, instead of the checkmark a cross is shown (invalid resource name) !!!!!!

    if i have a second OSX-calendar entry with the same resource at the same time it shows also a cross (resource is busy ?) !!!!!

    But it is not working as expected....
     

Share This Page