OSX Server DHCP service, decrease lease time

Discussion in 'Mac OS X Server, Xserve, and Networking' started by DennisBlah, Apr 14, 2015.

  1. DennisBlah, Apr 14, 2015
    Last edited: Apr 14, 2015

    DennisBlah macrumors 6502

    DennisBlah

    Joined:
    Dec 5, 2013
    Location:
    The Netherlands
    #1
    Hi all,

    I'm running an macPro with OSX Server (Yosemite) with a simple website and dhcp on osx server and dnsmasq for dns routing. Reason I choose for dnsmasq is discussed in DnS-Forwarding

    I'm now hitting the limit of my subnet with leasing ip adresses.

    All devices connected will be connected for max 5 - 10 minutes and then disconnect. But in settings I can only set the lease time to a minimum of 1 hour.

    Is there some way to decrease this time to 15 minutes ?

    Thanks!

    ----
    Also I don't seem to get DHCP to work with dnsmasq.
    Current config
    Code:
    listen-address=192.168.0.1
    interface=en0
    except-interface=en1
    no-dhcp-interface=en0   #comment out for dhcp
    no-dhcp-interface=en1
    
    #dhcp-range=192.168.0.50,192.168.3.254,5m  #DHCP RANGE
    #dhcp-option=3,192.168.0.1  #DHCP GATEWAY
    #dhcp-option=6,192.168.0.1  #DHCP DNS
    #server=192.168.0.1             #DHCP Server ?
    
    address=/#/192.168.0.1
    no-hosts
    
    
     
  2. dyt1983, Apr 14, 2015
    Last edited: Jun 2, 2015

    dyt1983 macrumors 65816

    Joined:
    May 6, 2014
    Location:
    USA USA USA
    #2
    edit: to remove personally identifying information not relevant to thread.
     
  3. DennisBlah thread starter macrumors 6502

    DennisBlah

    Joined:
    Dec 5, 2013
    Location:
    The Netherlands
    #3
    Hi Dyt!
    Thanks for the tip! I guess it's working, as the Server.app shows 5 minute now as lease time :) Awesome.

    I'm not netbooting and it's disabled. It's strictly for viewing a short video on the page located on the server (ONLY that page, thats why I'm using dnsmasq for dns).


    Thanks for clarification of the dnsmasq.
    What do you advice as DHCP ? The bootp from Server.app or dnsmasq since I already installed it and you are calling bootp robust ?
     
  4. dyt1983, Apr 14, 2015
    Last edited: Jun 2, 2015

    dyt1983 macrumors 65816

    Joined:
    May 6, 2014
    Location:
    USA USA USA
    #4
    edit: to remove personally identifying information not relevant to thread.
     
  5. DennisBlah thread starter macrumors 6502

    DennisBlah

    Joined:
    Dec 5, 2013
    Location:
    The Netherlands
    #5
    Thanks for all your help mate!
    Ill ser how it goed like it is now
    Dhcp on bootp and dns on dnsmasq

    Thanks again!
     
  6. DennisBlah thread starter macrumors 6502

    DennisBlah

    Joined:
    Dec 5, 2013
    Location:
    The Netherlands
    #6
    Hi Dyt,

    since you've chosen not to allow private messages, I just quote you again, and hope you will read this :)

    As you know pretty much apparently also of dnsmasq.

    I'm using this to forward all requests to my host.
    address=/#/192.168.0.1

    Why does this url not being forwarded? http://www.apple.com/nl
    I think it has to do with /nl

    How can I tackle this issue, and make sure that really ALL requests are going by 192.168.0.1 ?
     
  7. dyt1983, Apr 15, 2015
    Last edited: Jun 2, 2015

    dyt1983 macrumors 65816

    Joined:
    May 6, 2014
    Location:
    USA USA USA
    #7
    edit: to remove personally identifying information not relevant to thread.
     
  8. DennisBlah thread starter macrumors 6502

    DennisBlah

    Joined:
    Dec 5, 2013
    Location:
    The Netherlands
    #8
    ^^ in het nederlands ^^
    No it just goes nowhere

    I was hoping that there was a dnsmasq sollution possible. I'll just stick with my htaccess :) then

    Thanks again!!!
     
  9. dyt1983 macrumors 65816

    Joined:
    May 6, 2014
    Location:
    USA USA USA
    #9
    I think the simple "ErrorDocument 404 /" in your htaccess will work perfectly, as long as you have "AllowOverride All" set. I hope it is all working well for you now!
     
  10. DennisBlah thread starter macrumors 6502

    DennisBlah

    Joined:
    Dec 5, 2013
    Location:
    The Netherlands
    #10
    You keep getting kudo's mate...

    Everything is working fine :) thanks for asking!
     

Share This Page