osx software that looks like a page :S

Discussion in 'macOS' started by terramir, Apr 7, 2009.

  1. terramir macrumors newbie

    Joined:
    Apr 6, 2009
    #1
    okies I tried to install the gimps software on an emac I unzip it and it's a darn page with no extension
    what do I do with that program here's the link http://mersenne.org/freesoft/#newusers I downloaded the one that is not 64 bit I'm not sure that was the right one what is the g4? also is the 64 bit for intel processors:S

    Also the drystone benchmark I have the same problem here's that link
    http://download.cnet.com/dhrystone-Benchmark/3000-2094_4-97977.html?tag=mncol
    if you check out those files there is no default application to open it but it's supposed to be it's own application so what gives :S
    I know I know I'm a total PC geek therefore a total mac newb.
    Hey I wanna learn so I can utilize my newly from trash recovered eMac (already oc'ed :p) U see I oc everything LOL :p
    terramir
    PS: I want to get those two programs working for oc stablillity testing
     
  2. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
  3. terramir thread starter macrumors newbie

    Joined:
    Apr 6, 2009
    #3
    ty but how I do that ? I never used mac command line before:s
    terramir
     
  4. kostia macrumors regular

    Joined:
    Apr 14, 2007
    #4
    Both of these are command-line programs that run within Terminal. They are not the kind of ".app" programs that have a window of their own, and they are not documents.

    For dhrystone benchmark, if you know anyone who can read/translate Swedish, point them to http://www.ct.se and ask them what it says. There's almost no detail in English on the cnet site, and I don't see a link to an English version of their Swedish website.

    To run the program, download dhrystone.dmg and copy the "dhrystone" file to your desktop. Open Terminal and type:

    cd ~/Desktop

    then

    /usr/bin/open dhrystone

    The screen will show something like:

    yourname:/Users/yourname>/Users/yourname/Desktop/dhrystone ; exit;

    Wait a few seconds (or longer on that old eMac) and the program will report benchmark information for your machine. You'll know it's done when you see [Process completed] on the screen. I don't know what the information means ("This machine benchmarks at 19952949 dhrystones/second"), but that's what the program does.

    As for GIMPS, the program to search for prime numbers: You don't mention what OS is running on the eMac, but the 64-bit and "regular" version will both run on Leopard, and only the "regular" version on Tiger and earlier. It's nothing to do with the Intel processor, which your eMac probably doesn't have.

    I assume you've successfully expanded the .tar.gz file (the built-in Archive Utility program will do it, or Stuffit Expander). This gives you a folder with a bunch of text files plus the "mprime" program. Make sure that folder is on your desktop.

    Launch Terminal and type:

    cd ~/Desktop/mprime259-MacOSX

    This will put you into that folder.

    Then type:

    /usr/bin/open mprime

    This will launch the GIMPS program. It will prompt you for the information it needs. Once you get through all the options, choosing Test/Continue will start the work of looking for prime numbers. The website probably has more details; I just skimmed it.
     
  5. terramir thread starter macrumors newbie

    Joined:
    Apr 6, 2009
    #5
    tried the mersenne it in terminal gave me a bad cpu type on a g4 7445 (low voltage version):S
    Anyway now trying some other things
    ty for your help
    terramir
    PS: btw my emac benched at 4032583 dhrystones per second what are u running?
     

Share This Page