OSX will not connect to internet (but bootcamp will) - FIXED

Discussion in 'macOS' started by b_scott, Dec 5, 2010.

  1. b_scott, Dec 5, 2010
    Last edited: Dec 5, 2010

    b_scott macrumors 6502a

    b_scott

    Joined:
    Mar 31, 2008
    #1
    On Snow Leopard 10.6.5

    All of a sudden tonight I picked up my macbook pro and tried to browse the web. Nothing. I can connect to my router just fine, and I have the correct router IP, and I can config my router over WiFi, etc. Also, every other device in my house connects just fine. Also, when I boot into Windows 7 it connects just fine - however I get an exclamation in the task bar that says "No Internet Access" even though there is.

    I've tried flushing the DNS cache in terminal, no dice. I've cleared my Safari cache but didn't help. A couple times it has actually hit Gmail in all of the testing, but I could not duplicate this. I cannot ping gmail.com, yahoo.com, etc. My gmail notifier will not work, so it's not just my browser.

    I noticed the clock was wrong by about 6 hours, so I set it correctly. I also tried putting it back to auto-set another time. Neither worked after reboot.

    I'm on WiFi N and G, neither work. I also tried directly connecting to Ethernet, doesn't work. I rebooted the cable modem, router, and mac multiple times, nothing.

    I'm at my wit's end. Help!!! :mad::(:(:(
     
  2. iLog.Genius macrumors 601

    iLog.Genius

    Joined:
    Feb 24, 2009
    Location:
    Toronto, Ontario
    #2
    Try deleting the .plist:

    Macintosh HD/Library/Preferences/SystemConfiguration

    com.apple.airport.preferences.plist AND preferences.plist

    (Make sure AirPort is turned off before deleting those two files. You will have to enter in your login password and any network settings, password saved will be deleted)
     
  3. b_scott thread starter macrumors 6502a

    b_scott

    Joined:
    Mar 31, 2008
    #3
    thanks so much for your thoughtful answer and time - however, I just figured it out. Somehow the DNS settings on my router were changed or reset. I plugged in Open DNS IP's again and it works! Comcast's DNS servers must be down. I think most of my other devices are configured manually, but my OSX gets it from the router. Thanks again!
     
  4. NeverhadaPC macrumors 6502

    NeverhadaPC

    Joined:
    Oct 3, 2008
    #5
    Good to know I was not the only one fighting with my internet access... nothing was working but after changing the starting IP address back and forth and rebooting router and Airport Extreme along with my airport on my MBP, i finally got access to the web.
     

Share This Page