OSX Yosemite has Sharing Ethernet over WiFi problems

Discussion in 'OS X Yosemite (10.10)' started by VinegarTasters, Oct 19, 2014.

  1. VinegarTasters macrumors 6502

    VinegarTasters

    Joined:
    Nov 20, 2007
    #1
    Apparently, OSX Yosemite has problems sharing the Ethernet internet connection to WiFi users. This is a major problem. Apparently, only one
    device is able to connect and use the internet via WiFi. If you have more than
    one device, the other devices will hang and not get a connection (stuck on authorization). So if you have an iPhone and an iPad, only one can connect to the Mac (I have Mac Mini 2009 edition). Sometimes NONE will connect!

    I think I nailed it down to where the problem is... Firewall. Before, on Mavericks,
    I was able to connect multiple devices and share the Ethernet to go on the internet by letting OS X Mavericks share the ethernet connection over WiFI. After I upgraded to Yosemite, none could connect, or only one can connect.

    What is the solution? Turn off firewall. Apparently, the firewall is preventing devices from connecting and getting a shared connection to the Ethernet via WiFI. By turning it off, you can get a connection, then you can turn firewall back on.

    THIS IS WEIRD! Why is it happening? If you share your Ethernet to devices that connect via WiFI they don't need a new firewall setting to use Yosemite's Ethernet to access the internet! Something is terribly wrong. No QA?
     
  2. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #2
    Too many "apparently" - is this happening to you or not? When talking turning firewalls off I'd rather be talking to someone who has had a problem first-hand....
     
  3. mollerboller macrumors newbie

    Joined:
    Oct 19, 2014
    #3
    I have this problem !! All day, i hate it....

    1) under Mountain Lion it worked perfectly !
    2) under Mavericks i had to turn off the firewall to make it work
    3) under Yosemite it doesn't work at all !

    my problem is that i try to connect a fuhu nabi 2 using the imac as a hotspot
    sharing the ethernetline.

    when i try to sharing internet then the ethnernet connection collapses i can't get back into the internet unless i delete wlan and reset the dhcp...

    anyone got a solution ?
     
  4. Erlang macrumors member

    Joined:
    Dec 23, 2009
    Location:
    SW, UK
    #4
    I had Ethernet to WiFi sharing issue (it wouldn't).

    I solved it by checking the WiFi options under the sharing screen. This had been totally reset, during the update.

    Once all reset such as security WPA2 it all connected up.

    Hope this helps.

    Now to try and get iMessage to sign in on MP4.1 that my current mission.
     
  5. VinegarTasters thread starter macrumors 6502

    VinegarTasters

    Joined:
    Nov 20, 2007
    #5

    What do you mean reset? There is no reset option or button. Do you mean changing the default channel or naming? The sharing is really a problem. It will disconnect. You have to turn off firewall for it to connect again. I am unable to connect any devices via wifi sharing of the ethernet without turning off firewall and that is a security issue! I can't be turning off firewall just to connect devices to OS X Yosemite!
     
  6. fredric100 macrumors newbie

    Joined:
    Jan 16, 2007
    #6
    Fix Which Worked For Me

    Summary: Turn off the firewall, connect devices, turn on the firewall.

    Details:
    1. Turn off wifi Menu bar > Turn Wi-Fi Off
    2. Turn off internet sharing System Preferences > Sharing (uncheck)
    3. Turn off firewall System Preferences > Security & Privacy > Firewall > Turn Off Firewall
    4. Turn on wifi Menu bar > Turn Wi-Fi On
    5. Turn on internet sharing System Preferences > Sharing (check)
    6. Connect devices to the shared wifi connection
    7. Turn on firewall System Preferences > Security & Privacy > Firewall > Turn On Firewall
     
  7. VinegarTasters thread starter macrumors 6502

    VinegarTasters

    Joined:
    Nov 20, 2007
    #7

    Yes, but you can also just go into firewall and turn it off, wait for connection to succeed, then turn on firewall again. You don't need to turn off wifi or sharing.
    During the time when you are turning off firewall, don't use the internet or disconnect your ethernet cable (in the odd situation that you get a virus).

    Also, ever since the Mountain Lion update, if you change any of the network settings while Internet Sharing is on, you need to reboot to make internet sharing to work again (my other fix). This bug has been here since Mountain Lion!

    I have given up with reporting these WiFi bugs (officially and through forums). So maybe you have the patience to get Apple to fix them and push them through. My old apple reports on WiFi bugs since Mountain Lion are still in the system.

    Lets hope they fix this. Since my bugs are being ignored, maybe you have better luck.
     
  8. ziarn, Oct 22, 2014
    Last edited: Oct 22, 2014

    ziarn macrumors newbie

    Joined:
    Oct 22, 2014
    #8

    Attached Files:

  9. Erlang macrumors member

    Joined:
    Dec 23, 2009
    Location:
    SW, UK
    #9
    The upgrade to 10.10 had blanked all my WiFi setting for the share i.e. SSID, and password.

    However sharing still seems flaky, I have had to untick sharing wait a few seconds and re-tick and external idevices get a true connection to the LAN
     
  10. pdwalker macrumors newbie

    Joined:
    Dec 23, 2010
    #10
    what the problem is

    The firewall appears to be preventing the dhcp server from giving out ip addresses, hence your inability to connect.

    disable the firewall, get your ip, and reconnect your firewall.

    this is a new "bug" since 10.9.
     
  11. cawas macrumors newbie

    cawas

    Joined:
    Jan 15, 2010
  12. xanketsu macrumors newbie

    Joined:
    Jan 21, 2015
    #12
    I have similar problem

    Suddenly, both my 8.0.2 iPad & 6.1.0 iPod Touch can longer connect to shared internet connection by my 10.10.0 Macbook Pro (ethernet to wifi).

    Rebooting both the iPad & MBP didn't solve the problem. Turning off the firewall didn't work either. Deleting plist ... resetting SMC ... no luck.

    It probably has something to do with this console report, although I'm not sure.

    15.01.21 22:10:13.587 configd[26]: [bootp_transmit.c:213] bootp_transmit(): bpf_write(en1) failed: Device not configured (6)

    15.01.21 22:10:13.587 configd[26]: DHCP en1: INIT transmit failed
    15.01.21 22:14:23.214 configd[26]: inet_set_autoaddr(en1, 1) failed, Resource busy (16)

    15.01.21 22:17:01.895 com.apple.xpc.launchd[1]: assertion failed: 14A389: launchd + 160118 [55B9FF23-B298-321A-B776-CF7676586C04]: 0xe


    Any ideas?
     
  13. rageinjapan macrumors newbie

    Joined:
    Oct 15, 2009
    #13
    Ethernet sharing with Yosemite.

    I upgraded to Yosemite 10.10.3 last night and since then I am unable to share my internet with wifi. Not sure what the problem is. I have tried just about everything I can think of and everything that is on this thread. My Imac is a late 2009 model and I am able to connect to wifi for about 30 seconds and then it quits. Before upgrading I was using Maverick and had no problems. My ethernet connnection for the imac is working fine. Very frustrating because my ipad and ps3 don't have internet now. Any suggestions would be greatly appreciated.
     
  14. m3kw macrumors newbie

    Joined:
    Mar 4, 2011
    #14

    In the Ethernet interface where you will share the internet, make sure you don't use DHCP because it is not the interface that needs DHCP(it doesn't actually need an IP address, the device connected to it needs one). I set it to BootP and it worked even though the interface shows Red, it will work.
     

Share This Page