OSX Yosemite won't let me log in

Discussion in 'OS X Yosemite (10.10)' started by bbqeggs, Oct 18, 2014.

  1. bbqeggs macrumors newbie

    Joined:
    Oct 18, 2014
    #1
    I just upgraded my Macbook Pro (late 2008) to Yosemite today and after the instillation finished it asks me to log in (as it does whenever the computer restarts). However this time it does not accept my password to log in. Every time i try and log in the screen shakes and prevents me from logging in. I have not changed my password on my computer, ever. I have used the same password for years. I thought, maybe it could be asking for my apple ID password (which is different) but that does not work either.

    I checked to make sure caps lock was not on (it wasn't and I still had problems) then I put caps lock on to see if that would fix it (it didn't), then I tried every iteration of my password that I could think of, then I tried every other password I use just to see if there is some mix up somewhere. All of these did not work out at all. I still cannot log into my profile at all. Although I can still log in a a guest. I think that means the install itself worked, just not my password.

    I googled and did not find anyone else with this issue. Is there a way to fix this?
     
  2. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #2
    Boot in Recovery mode. Then using Terminal in Recovery Mode and type

    Code:
    resetpassword

    A box will open up to change a password.
     
  3. bbqeggs thread starter macrumors newbie

    Joined:
    Oct 18, 2014
    #3
  4. Swagged macrumors regular

    Joined:
    Nov 14, 2011
    Location:
    Gotham City, New York
    #4
    It's really that easy? If so, then someone with a bit of mac savvy could easily change someone's password....
     
  5. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #5
    That's why Apple has Firmware Password.
     
  6. marvz macrumors 6502a

    marvz

    Joined:
    Aug 27, 2012
    Location:
    Berlin
    #6
    Had the same problem. But then I noticed that the US keyboard was in use after rebooting so I just had to change it in the upper right hand corner. (After trying my password 1000 times :mad: )
     
  7. Alrescha macrumors 68020

    Joined:
    Jan 1, 2008
    #7
    If you have physical access to a Mac, PC, Linux box, etc., then you are in control of that machine. If this is of concern to you then use encryption to protect the contents.

    A.
     
  8. doublep macrumors newbie

    Joined:
    Sep 3, 2011
    Location:
    Japan
    #8
    I had the same issue. I also noticed, after several heart-stopping tries, that the system had reverted to a US keyboard (I use a French keyboard).
     

Share This Page