OSX10.8.5supp incompatible with NVidia 313.01.03f01

Discussion in 'Mac Pro' started by MassMacMan, Oct 3, 2013.

  1. MassMacMan macrumors regular

    Joined:
    Jul 12, 2012
    Location:
    Boston MetroWest
    #1
    Title says it all. I just installed the Apple OSX 10.8.5 supplementary update, and now the NVidia web driver doesn't work. See link here.

    The good news is that the OSX driver for my GTX 580 / GT 120 combo GPU setup allows OpenCL, since both cards (and the CPU) report OpenCL 1.2. Finally I can run LuxMark and OpenCL_OceanWave benchmarks!
     
  2. Demigod Mac macrumors 6502a

    Joined:
    Apr 25, 2008
    #2
    What exactly happened, I'm curious? Blank screens, error messages?
     
  3. MassMacMan, Oct 3, 2013
    Last edited: Oct 4, 2013

    MassMacMan thread starter macrumors regular

    Joined:
    Jul 12, 2012
    Location:
    Boston MetroWest
    #3
    The computer booted up normally, but when I activated the NVidia Driver Manager, it reported on the Updates tab "Nvidia Web Driver: 313.01.03f01 (Not compatible)". The OS X Default Driver is selected, and the web driver button is grayed out.

    OTOH, performance on the OS X driver seems excellent. On LuxMark, I'm getting scores of 1284 with the GTX 580 alone on the Sala benchmark, and 1785 using the CPU and the GTX 580. I'll let you know what I get when NVidia posts a new web driver.
     
  4. MacVidCards Suspended

    Joined:
    Nov 17, 2008
    Location:
    Hollywood, CA
    #4
    Yay !!!

    Fingers crossed that they will take advantage of this opportunity to fix OpenCl for GK110 in ML.
     
  5. MassMacMan thread starter macrumors regular

    Joined:
    Jul 12, 2012
    Location:
    Boston MetroWest
    #5
    Well, this certainly fixes OpenCL in ML for me. With an early 2009 Mac Pro (flashed to 5.1 and running a 3.33 gHz hex core), even though I still have my legacy GT 120 in the machine, it's getting super benchmark scores in LuxMark. I just posted my results using just the one GPU and the CPU onto the LuxMark Results Database for medium benchmark results (Sala). Out of 256 results posted for 1 GPU + 1 CPU, my machine made the top 10, beating a Tahiti + i7-3770K CPU @ 3.50GHz as well as an HD7970 + the same CPU as mine.

    Color me happy. Thanks to MacVidCards for flashing an excellent GTX 580!

    --Mike
     
  6. pastrychef macrumors 601

    pastrychef

    Joined:
    Sep 15, 2006
    Location:
    New York City, NY
    #6
    I'm also seeing some slight improvements from Luxmark. I got 384 for room and 777 for sala.
     
  7. Redneck1089 macrumors 65816

    Redneck1089

    Joined:
    Jan 18, 2004
    #7
    Is this still a problem, or is it safe to install the supplementary update now?
     
  8. pastrychef macrumors 601

    pastrychef

    Joined:
    Sep 15, 2006
    Location:
    New York City, NY
    #8
    It's only a problem if you need the Nvidia web drivers. If you use Apple's built-in drivers, there are no problems.
     

Share This Page